summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-12-04 20:23:04 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-12-04 20:27:21 +0100
commit2c6390a5d0c01420879e9f23bc89afb19976da4a (patch)
tree620d0960678c6265eb1dbe93b3742ad8a0dc2ffe /package/Makefile.package.in
parent2dda9ea0d31d30c990a2cb76b764e80c4ed06ca3 (diff)
dependencies: check for extract tools as well
Most of the extract tools (gzip/bzip/..) we already check for explicitly in dependencies.sh (as they are used outside GENTARGETS), but not for xzcat. The .xz format is used fairly rarely, and it is likely to not be available on build hosts, so an explicit (hardcoded) check for it isn't optimal. Instead, add the inflate tools used to DL_TOOLS_DEPENDENCIES, similar to how we do it for svn/git/bzr/... Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 2349b05af..e85eb1549 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -726,6 +726,8 @@ else ifeq ($$($(2)_SITE_METHOD),hg)
DL_TOOLS_DEPENDENCIES += hg
endif # SITE_METHOD
+DL_TOOLS_DEPENDENCIES += $(firstword $(INFLATE$(suffix $($(2)_SOURCE))))
+
endif # $(2)_KCONFIG_VAR
endef # GENTARGETS_INNER