summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-30 20:45:56 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-02 20:55:55 +0200
commit31960961497ebc1059978c54c7d65a08a8b7e821 (patch)
tree38e2ba32b372eceeb3dffb9e1a124532cd2ce7b1 /package/Makefile.package.in
parentd6e9b16b37940fc1377f7f3dc2c5cac3a4baca76 (diff)
package: fix bootloader building
The changes in e055aea216cff4d12cf55eab2e35ca1459edaa91 and 0849e8193ef429f29945b8c2a54eafc8635e0969 have broken the bootloader support. This is because the 'pkgparentdir' macro returns the string 'boot/' for bootloaders, while the GENTARGETS_INNER macro was testing this against 'boot' to know if the configuration option to check for this package is BR2_PACKAGE_* or BR2_TARGET_*. So, instead of testing against 'boot', we test against 'boot/'. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 353ba72a0..b5ef57bb1 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -637,7 +637,7 @@ $$($(2)_TARGET_DIRCLEAN): PKG=$(2)
# kernel case, the bootloaders case, and the normal packages case.
ifeq ($(1),linux)
$(2)_KCONFIG_VAR = BR2_LINUX_KERNEL
-else ifeq ($(4),boot)
+else ifeq ($(4),boot/)
$(2)_KCONFIG_VAR = BR2_TARGET_$(2)
else
$(2)_KCONFIG_VAR = BR2_PACKAGE_$(2)