summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-19 22:10:52 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-20 22:18:14 +0200
commit33518020ba93b739252f6d7f82bc48e6cbf3100a (patch)
tree85d893634f76a4f23126d3e78aff69543b8e0493 /package/Makefile.package.in
parent8ca82530b837542a56a4aa728331d97639f6e533 (diff)
package: add a PRE_PATCH_HOOKS hook point
This will be useful to integrate Xenomai and RTAI into Buildroot, so that they can patch the kernel before the normal patching process starts. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 66be0a237..e2d0e28ce 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -259,6 +259,7 @@ $(BUILD_DIR)/%/.stamp_extracted:
$(BUILD_DIR)/%/.stamp_patched: NAMEVER = $(RAWNAME)-$($(PKG)_VERSION)
$(BUILD_DIR)/%/.stamp_patched:
@$(call MESSAGE,"Patching $($(PKG)_DIR_PREFIX)/$(RAWNAME)")
+ $(foreach hook,$($(PKG)_PRE_PATCH_HOOKS),$(call $(hook))$(sep))
$(if $($(PKG)_PATCH),support/scripts/apply-patches.sh $(@D) $(DL_DIR) $($(PKG)_PATCH))
$(Q)( \
if test -d $($(PKG)_DIR_PREFIX)/$(RAWNAME); then \
@@ -443,6 +444,7 @@ $(2)_EXTRACT_CMDS ?= \
# post-steps hooks
$(2)_POST_DOWNLOAD_HOOKS ?=
$(2)_POST_EXTRACT_HOOKS ?=
+$(2)_PRE_PATCH_HOOKS ?=
$(2)_POST_PATCH_HOOKS ?=
$(2)_PRE_CONFIGURE_HOOKS ?=
$(2)_POST_CONFIGURE_HOOKS ?=