summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-29 21:57:39 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-29 22:21:51 +0200
commit4ed4e5016b741341059ed826416dad3291df0b2c (patch)
treeb69d243093d3cbc763efd369a69956edd37ca3b3 /package/Makefile.package.in
parentee0246e1e1d83f41985489c85dfef07098a2026d (diff)
package: add <pkg>-rebuild and <pkg>-reconfigure
We are often asked "how can I restart the build of a package ?" or "how can I restart the build of package from the configure part ?". Obviously, tweaking with stamp files is possible, but not very user friendly. Therefore this patch adds two new per-package targets: <pkg>-rebuild and <pkg>-reconfigure. They will remove the right stamp files and restart the complete build process (by using the 'all' target, so that not only the package is reconfigured, recompiled and reinstalled, but the root filesystem images are also regenerated). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 15fc08541..53cc8eba0 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -557,6 +557,22 @@ $(1)-clean: $(1)-uninstall \
$(1)-dirclean: $$($(2)_TARGET_DIRCLEAN)
+$(1)-clean-for-rebuild:
+ifneq ($$($(2)_OVERRIDE_SRCDIR),)
+ rm -f $$($(2)_TARGET_RSYNC)
+endif
+ rm -f $$($(2)_TARGET_BUILD)
+ rm -f $$($(2)_TARGET_INSTALL_STAGING)
+ rm -f $$($(2)_TARGET_INSTALL_TARGET)
+ rm -f $$($(2)_TARGET_INSTALL_HOST)
+
+$(1)-rebuild: $(1)-clean-for-rebuild all
+
+$(1)-clean-for-reconfigure: $(1)-clean-for-rebuild
+ rm -f $$($(2)_TARGET_CONFIGURE)
+
+$(1)-reconfigure: $(1)-clean-for-reconfigure all
+
# define the PKG variable for all targets, containing the
# uppercase package variable prefix
$$($(2)_TARGET_INSTALL_TARGET): PKG=$(2)