summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-12-06 16:40:11 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-27 22:00:59 +0100
commit6908149bec720e6bb4c2d1e8d03331bcd4e3343b (patch)
tree4a6b414eed8b4c275ba5cb087448951e4d7112b9 /package/Makefile.package.in
parent12989b062639897a9fd3734848eb87d1bfdc6d23 (diff)
package infra: fix versioned patches for host packages
Without this patch we'd need separate versioned patch directories for target and host packages, thus having unwanted duplication. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index c4a1cf8ee..92ce4e22f 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -267,7 +267,7 @@ $(BUILD_DIR)/%/.stamp_patched:
toolchain/patch-kernel.sh $(@D) $($(PKG)_DIR_PREFIX)/$($(NOHOSTPKG)_NAME) $(NAMEVER)\*.patch $(NAMEVER)\*.patch.$(ARCH) || exit 1; \
else \
toolchain/patch-kernel.sh $(@D) $($(PKG)_DIR_PREFIX)/$($(NOHOSTPKG)_NAME) $($(NOHOSTPKG)_NAME)\*.patch $($(NOHOSTPKG)_NAME)\*.patch.$(ARCH) || exit 1; \
- if test -d $($(PKG)_DIR_PREFIX)/$($(PKG)_NAME)/$(NAMEVER); then \
+ if test -d $($(PKG)_DIR_PREFIX)/$($(NOHOSTPKG)_NAME)/$(NAMEVER); then \
toolchain/patch-kernel.sh $(@D) $($(PKG)_DIR_PREFIX)/$($(NOHOSTPKG)_NAME)/$(NAMEVER) \*.patch \*.patch.$(ARCH) || exit 1; \
fi; \
fi; \