summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-03-12 22:10:56 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-03-12 22:10:56 +0100
commit7266ed46535c4195e2f5cbd644bc5745992b043e (patch)
tree2b206e4ce6ccb6eca03560dbca8cb2fb7de3f739 /package/Makefile.package.in
parent05955603ce67259d8adfcea6f43033279a13dbae (diff)
Makefile.package.in: make <pkg>_SOURCE optional
For packages where the sources are included in buildroot (E.G. makedevs). We unfortunately already use no <pkg>_SOURCE to mean <pkg>_<version>.tar.gz, in several packages (and for git/svn/bzr support), so you need to define <pkg>_SOURCE to the empty string to use it. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 92ce4e22f..84687d58e 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -232,7 +232,7 @@ ifeq ($(DL_MODE),DOWNLOAD)
(test -z $($(PKG)_PATCH) || test -e $(DL_DIR)$($(PKG)_PATCH))) || \
$(call MESSAGE,"Downloading")
endif
- $(call DOWNLOAD,$($(PKG)_SITE),$($(PKG)_SOURCE))
+ $(if $($(PKG)_SOURCE),$(call DOWNLOAD,$($(PKG)_SITE),$($(PKG)_SOURCE)))
$(if $($(PKG)_PATCH),$(call DOWNLOAD,$($(PKG)_SITE),$($(PKG)_PATCH)))
ifeq ($(DL_MODE),DOWNLOAD)
$(Q)mkdir -p $(@D)
@@ -243,8 +243,8 @@ endif
$(BUILD_DIR)/%/.stamp_extracted:
@$(call MESSAGE,"Extracting")
$(Q)mkdir -p $(@D)
- $(Q)$(INFLATE$(suffix $($(PKG)_SOURCE))) $(DL_DIR)/$($(PKG)_SOURCE) | \
- $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
+ $(Q)$(if $($(PKG)_SOURCE),$(INFLATE$(suffix $($(PKG)_SOURCE))) $(DL_DIR)/$($(PKG)_SOURCE) | \
+ $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -)
# some packages have messed up permissions inside
$(Q)chmod -R ug+rw $(@D)
$(foreach hook,$($(PKG)_POST_EXTRACT_HOOKS),$(call $(hook))$(sep))