summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-09-29 21:57:51 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-09-30 08:26:08 +0200
commit767ad6900a68fe92f4d725ecb1e6dfa248ab53f9 (patch)
tree06065bd21e7a687ae1567d49a20972f407b6a76b /package/Makefile.package.in
parent9e045df4e12b268417f62f70df4afc1441f8efbf (diff)
package: normalize output of 'make external-deps'
For wget-downloaded packages, only the tarball name was displayed, while for svn/git/bzr packages, the complete repository URL was shown. As discussed on the list, what we want for 'make external-deps' is only the tarball name even for git/svn/bzr downloads. For local packages, we of course keep the full path since it's the only information that we can provide. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 10212061f..353ba72a0 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -141,7 +141,7 @@ define SOURCE_CHECK_GIT
endef
define SHOW_EXTERNAL_DEPS_GIT
- echo "$($(PKG)_SITE) [git: $($(PKG)_DL_VERSION)]"
+ echo $($(PKG)_SOURCE)
endef
@@ -155,7 +155,7 @@ define SOURCE_CHECK_BZR
endef
define SHOW_EXTERNAL_DEPS_BZR
- echo "$($(PKG)_SITE) [bzr: $($(PKG)_DL_VERSION)]"
+ echo $($(PKG)_SOURCE)
endef
@@ -173,7 +173,7 @@ define SOURCE_CHECK_SVN
endef
define SHOW_EXTERNAL_DEPS_SVN
- echo "$($(PKG)_SITE) [svn: $($(PKG)_DL_VERSION)]"
+ echo $($(PKG)_SOURCE)
endef