summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorLionel Landwerlin <llandwerlin@gmail.com>2010-11-04 03:50:24 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-05 10:03:29 +0100
commit89d1ad91fe4b1b65f0e902f94aba99a6cefbf631 (patch)
tree0e60718831c6079622aeff26b0ec283c40f95ef5 /package/Makefile.package.in
parent3256bcafb57999b3807ef73e4525ee5d2e462668 (diff)
package: move autoreconfigure step to pre configure hook
[Peter: update documentation to match] Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 377df65c0..816a01323 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -261,6 +261,7 @@ $(BUILD_DIR)/%/.stamp_patched:
# Configure
$(BUILD_DIR)/%/.stamp_configured:
+ $(foreach hook,$($(PKG)_PRE_CONFIGURE_HOOKS),$(call $(hook))$(sep))
@$(call MESSAGE,"Configuring")
$($(PKG)_CONFIGURE_CMDS)
$(foreach hook,$($(PKG)_POST_CONFIGURE_HOOKS),$(call $(hook))$(sep))
@@ -410,6 +411,7 @@ $(2)_TARGET_DIRCLEAN = $$($(2)_DIR)/.stamp_dircleaned
# post-steps hooks
$(2)_POST_EXTRACT_HOOKS ?=
$(2)_POST_PATCH_HOOKS ?=
+$(2)_PRE_CONFIGURE_HOOKS ?=
$(2)_POST_CONFIGURE_HOOKS ?=
$(2)_POST_BUILD_HOOKS ?=
$(2)_POST_INSTALL_HOOKS ?=