summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-24 15:57:29 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-24 17:48:26 +0100
commit960d268b25f61c407056c2eba946612a38d7de9f (patch)
tree3632fbf42a6a99fef49ba08766a1530df4da69e0 /package/Makefile.package.in
parentac294cf557f0d6053373d9af3471300a12f28d1c (diff)
infrastructure: only require download tools when needed
Instead of having to require svn, git or bzr unconditionally, only require them when one package needs them to be downloaded. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in14
1 files changed, 12 insertions, 2 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 428dbcbb5..c4a1cf8ee 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -504,9 +504,19 @@ $$($(2)_TARGET_DIRCLEAN): PKG=$(2)
# configuration
ifeq ($$(BR2_PACKAGE_$(2)),y)
+
TARGETS += $(1)
-endif
-endef
+
+ifeq ($$($(2)_SITE_METHOD),svn)
+DL_TOOLS_DEPENDENCIES += svn
+else ifeq ($$($(2)_SITE_METHOD),git)
+DL_TOOLS_DEPENDENCIES += git
+else ifeq ($$($(2)_SITE_METHOD),bzr)
+DL_TOOLS_DEPENDENCIES += bzr
+endif # SITE_METHOD
+
+endif # BR2_PACKAGE_$(2)
+endef # GENTARGETS_INNER
################################################################################
# GENTARGETS -- the target generator macro for generic packages