summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-01-16 14:58:35 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-17 23:28:47 +0100
commitbbc53fa8446a4106eb666310f19a9bfbd0b4f3c7 (patch)
tree90a62e037cc29d0578e609bfc6158290c44200dc /package/Makefile.package.in
parentfcc7cd3c7b42a2ff829a0cf7d28894cff3a89660 (diff)
package: derive HOST_FOO_DEPENDENCIES from FOO_DEPENDENCIES
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index e85eb1549..a27804b81 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -542,7 +542,12 @@ $(2)_OVERRIDE_SRCDIR = $($(2)_SITE)
endif
endif
-$(2)_DEPENDENCIES ?=
+ifndef $(2)_DEPENDENCIES
+ ifdef $(3)_DEPENDENCIES
+ $(2)_DEPENDENCIES = $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
+ endif
+endif
+
$(2)_INSTALL_STAGING ?= NO
$(2)_INSTALL_IMAGES ?= NO
$(2)_INSTALL_TARGET ?= YES