summaryrefslogtreecommitdiff
path: root/package/Makefile.package.in
diff options
context:
space:
mode:
authorJean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>2011-03-16 17:07:08 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-03-16 22:46:52 +0100
commitf7abec2d1d1e52f49f7d95c48165cde8cf41edb6 (patch)
tree07a1e9156a21d71a1c6fa4703e8ef2a9a2a85802 /package/Makefile.package.in
parentb922f6404dfc64259077f1ef7b7f545b99397413 (diff)
fetch/git: clone the repository as bare
This will reduce the space used and speed up the clone as it is only used to generate an archive, which doesn't need the git working tree. Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.package.in')
-rw-r--r--package/Makefile.package.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.package.in b/package/Makefile.package.in
index 84687d58e..bf4e1b49a 100644
--- a/package/Makefile.package.in
+++ b/package/Makefile.package.in
@@ -105,7 +105,7 @@ endif
define DOWNLOAD_GIT
test -e $(DL_DIR)/$($(PKG)_SOURCE) || \
(pushd $(DL_DIR) > /dev/null && \
- $(GIT) clone $($(PKG)_SITE) $($(PKG)_BASE_NAME) && \
+ $(GIT) clone --bare $($(PKG)_SITE) $($(PKG)_BASE_NAME) && \
pushd $($(PKG)_BASE_NAME) > /dev/null && \
$(GIT) archive --format=tar --prefix=$($(PKG)_BASE_NAME)/ $($(PKG)_DL_VERSION) | \
gzip -c > $(DL_DIR)/$($(PKG)_SOURCE) && \