summaryrefslogtreecommitdiff
path: root/package/avahi
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-01-28 15:12:05 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-01-28 15:12:05 +0000
commit7b83993c3e92c06521278e864e9c112e0ec6aefe (patch)
tree54e9a57e937518ee2ffb309756b7add4b4f0f927 /package/avahi
parentd608e26d486986a9b1a9e078157025e052e926a5 (diff)
avahi-autoipd: fix issue with repeated builds
The avahi-autoipd target install step adds /var/lib/avahi-autoipd as a symlink to /tmp/avahi-autoipd, which is fine, except if your /var/lib is already a symlink to /tmp (E.G. like the default target_skeleton is). If that's the case, then you end up adding a /tmp/avahi-autoipd symlink pointing to itself, causing subsequent builds to fail (Too many levels of symbolic links in the ln -sf call). Fix it by simply first removing the symlink if it's there.
Diffstat (limited to 'package/avahi')
-rw-r--r--package/avahi/avahi.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index f44ef1f3d..a013509d1 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -158,6 +158,7 @@ $(TARGET_DIR)/usr/sbin/avahi-autoipd: $(AVAHI_DIR)/.installed
chmod 0755 $(TARGET_DIR)/usr/share/udhcpc/default.script
cp -af package/avahi/S05avahi-setup.sh $(TARGET_DIR)/etc/init.d/
cp $(STAGING_DIR)/usr/sbin/avahi-autoipd $@
+ rm -f $(TARGET_DIR)/var/lib/avahi-autoipd
ln -sf /tmp/avahi-autoipd $(TARGET_DIR)/var/lib/avahi-autoipd
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@