summaryrefslogtreecommitdiff
path: root/package/busybox
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-03-20 08:53:17 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-03-20 08:53:17 +0000
commitd9ae4dd945e2ba7daca92448a0563c9399942c19 (patch)
tree601f8103ecf3dd680ce8a436ac5fd5f58b7b8f50 /package/busybox
parent5754880c4ae2e341f2fddd4220e3289e6c50a4d2 (diff)
- add busybox-1.4.2
Diffstat (limited to 'package/busybox')
-rw-r--r--package/busybox/Config.in8
-rw-r--r--package/busybox/busybox.fix-ptr_to_globals.patch11
-rw-r--r--package/busybox/busybox.mdev-just-read-9-bytes.patch13
-rw-r--r--package/busybox/busybox.mk5
4 files changed, 13 insertions, 24 deletions
diff --git a/package/busybox/Config.in b/package/busybox/Config.in
index 9d9c1a1e9..88d54fba2 100644
--- a/package/busybox/Config.in
+++ b/package/busybox/Config.in
@@ -18,18 +18,25 @@ choice
config BR2_BUSYBOX_VERSION_1_0_1
bool "BusyBox 1.0.1"
+ depends on BR2_DEPRECATED
config BR2_BUSYBOX_VERSION_1_1_3
bool "BusyBox 1.1.3"
+ depends on BR2_DEPRECATED
config BR2_BUSYBOX_VERSION_1_2_2_1
bool "BusyBox 1.2.2.1"
config BR2_BUSYBOX_VERSION_1_4_0
bool "BusyBox 1.4.0"
+ depends on BR2_DEPRECATED
config BR2_BUSYBOX_VERSION_1_4_1
bool "BusyBox 1.4.1"
+ depends on BR2_DEPRECATED
+
+ config BR2_BUSYBOX_VERSION_1_4_2
+ bool "BusyBox 1.4.2"
config BR2_PACKAGE_BUSYBOX_SNAPSHOT
bool "daily snapshot"
@@ -60,6 +67,7 @@ config BR2_PACKAGE_BUSYBOX_CONFIG
default "package/busybox/busybox-1.2.2.1.config" if BR2_BUSYBOX_VERSION_1_2_2_1
default "package/busybox/busybox-1.4.0.config" if BR2_BUSYBOX_VERSION_1_4_0
default "package/busybox/busybox-1.4.1.config" if BR2_BUSYBOX_VERSION_1_4_1
+ default "package/busybox/busybox-1.4.1.config" if BR2_BUSYBOX_VERSION_1_4_2
help
Some people may wish to use their own modified BusyBox configuration
file, and will specify their config file location with this option.
diff --git a/package/busybox/busybox.fix-ptr_to_globals.patch b/package/busybox/busybox.fix-ptr_to_globals.patch
deleted file mode 100644
index 36a4dbfcd..000000000
--- a/package/busybox/busybox.fix-ptr_to_globals.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-Index: busybox/libbb/messages.c
-===================================================================
---- busybox/libbb/messages.c (revision 18097)
-+++ busybox/libbb/messages.c (working copy)
-@@ -56,4 +56,5 @@ WTMP_FILE;
-
- char bb_common_bufsiz1[BUFSIZ+1];
-
--void *ptr_to_globals;
-+struct global1;
-+struct global1 *ptr_to_globals;
diff --git a/package/busybox/busybox.mdev-just-read-9-bytes.patch b/package/busybox/busybox.mdev-just-read-9-bytes.patch
deleted file mode 100644
index 5742fd597..000000000
--- a/package/busybox/busybox.mdev-just-read-9-bytes.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: busybox/util-linux/mdev.c
-===================================================================
---- busybox/util-linux/mdev.c (revision 17891)
-+++ busybox/util-linux/mdev.c (working copy)
-@@ -39,7 +39,7 @@
-
- if (!delete) {
- strcat(path, "/dev");
-- len = open_read_close(path, temp + 1, 64);
-+ len = open_read_close(path, temp + 1, 9);
- *temp++ = 0;
- if (len < 1) return;
- }
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index c35295838..1574e9a50 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -24,6 +24,11 @@ ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_4_1)),y)
BUSYBOX_VER:=1.4.1
endif
+ifeq ($(strip $(BR2_BUSYBOX_VERSION_1_4_2)),y)
+BUSYBOX_VER:=1.4.2
+endif
+
+
ifeq ($(strip $(BR2_PACKAGE_BUSYBOX_SNAPSHOT)),y)
# Be aware that this changes daily....
BUSYBOX_DIR:=$(BUILD_DIR)/busybox