summaryrefslogtreecommitdiff
path: root/package/config/patches/06-br-build-system-integration.patch
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-02 17:08:11 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-02 17:08:11 +0200
commite62ed84b19d114870daf1f16aae177f60f9d6ad3 (patch)
tree9b3471d639525410bd65e36c5e5aa94b77c29a28 /package/config/patches/06-br-build-system-integration.patch
parent9bc12b85e83266c83f1fee0b9dd2d38e43d9252c (diff)
parent40177240fab04c710fd756a24816b451b37dc1b8 (diff)
Merge branch 'for-2010.11/kconfig-upgrade' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'package/config/patches/06-br-build-system-integration.patch')
-rw-r--r--package/config/patches/06-br-build-system-integration.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/package/config/patches/06-br-build-system-integration.patch b/package/config/patches/06-br-build-system-integration.patch
new file mode 100644
index 000000000..128bbc02c
--- /dev/null
+++ b/package/config/patches/06-br-build-system-integration.patch
@@ -0,0 +1,40 @@
+---
+ Makefile | 14 +++++++++++++-
+ 1 file changed, 13 insertions(+), 1 deletion(-)
+
+Index: config/Makefile
+===================================================================
+--- config.orig/Makefile
++++ config/Makefile
+@@ -177,18 +177,30 @@
+ ifeq ($(MAKECMDGOALS),nconfig)
+ hostprogs-y += nconf
+ endif
++ifeq ($(findstring nconf,$(MAKECMDGOALS)),nconf)
++ hostprogs-y += nconf
++endif
+
+ ifeq ($(MAKECMDGOALS),menuconfig)
+ hostprogs-y += mconf
+ endif
++ifeq ($(findstring mconf,$(MAKECMDGOALS)),mconf)
++ hostprogs-y += mconf
++endif
+
+ ifeq ($(MAKECMDGOALS),xconfig)
+ qconf-target := 1
+ endif
++ifeq ($(findstring qconf,$(MAKECMDGOALS)),qconf)
++ qconf-target := 1
++endif
++
+ ifeq ($(MAKECMDGOALS),gconfig)
+ gconf-target := 1
+ endif
+-
++ifeq ($(findstring gconf,$(MAKECMDGOALS)),gconf)
++ gconf-target := 1
++endif
+
+ ifeq ($(qconf-target),1)
+ qconf-cxxobjs := qconf.o