summaryrefslogtreecommitdiff
path: root/package/config/patches/15-misc-qconf-changes.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-21 15:59:10 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-09-01 12:26:41 +0200
commit7c524dd0b683e1e8fac4e4084ac7678576bfbe07 (patch)
tree557327667ec2d0bf0bdb94894a4452c4ad8908c5 /package/config/patches/15-misc-qconf-changes.patch
parent6f38119cbb2cf5dd9c64109ff331a3d3868460ff (diff)
Clean up our patches against kconfig
Our kconfig-to-buildroot2.patch hasn't been kept up to date with all the changes made into package/config, and a single patch wasn't very practical to maintain all our changes. Therefore, this commit adds a package/config/patches directory, which contains a Quilt series of patches that correspond to our modifications to the kconfig mechanism. The huge kconfig-to-buildroot2.patch has been split into 16 smaller patches. The purpose of some of the modifications has been clearly identified, while some others were not identified. The 16 patches together do match exactly the old kconfig-to-buildroot2.patch. We have been very careful in making sure that we wouldn't loose any of our modifications. The only modifications made are : * Instead of renaming the kernel Makefile to Makefile.kconfig and naming the Buildroot Makefile just 'Makefile', we instead keep the original package/config/Makefile from the kernel scripts/kconfig/Makefile and name the Buildroot Makefile package/config/Makefile.br. The main Buildroot Makefile is modified accordingly. * The documentation README.buildroot2 is updated to explain how to upgrade to a newer version of scripts/kconfig. * The kconfig-language.txt documentation is removed, as anybody can easily find it in the kernel sources so there's no need to duplicate it here. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/config/patches/15-misc-qconf-changes.patch')
-rw-r--r--package/config/patches/15-misc-qconf-changes.patch175
1 files changed, 175 insertions, 0 deletions
diff --git a/package/config/patches/15-misc-qconf-changes.patch b/package/config/patches/15-misc-qconf-changes.patch
new file mode 100644
index 000000000..683d518f1
--- /dev/null
+++ b/package/config/patches/15-misc-qconf-changes.patch
@@ -0,0 +1,175 @@
+---
+ qconf.cc | 48 +++++++++++++++++++++++++++---------------------
+ 1 file changed, 27 insertions(+), 21 deletions(-)
+
+Index: config.clean/qconf.cc
+===================================================================
+--- config.clean.orig/qconf.cc
++++ config.clean/qconf.cc
+@@ -5,6 +5,7 @@
+
+ #include <qapplication.h>
+ #include <qmainwindow.h>
++#include <qdesktopwidget.h>
+ #include <qtoolbar.h>
+ #include <qlayout.h>
+ #include <qvbox.h>
+@@ -297,10 +298,10 @@
+ void ConfigLineEdit::keyPressEvent(QKeyEvent* e)
+ {
+ switch (e->key()) {
+- case Key_Escape:
++ case Qt::Key_Escape:
+ break;
+- case Key_Return:
+- case Key_Enter:
++ case Qt::Key_Return:
++ case Qt::Key_Enter:
+ sym_set_string_value(item->menu->sym, text().latin1());
+ parent()->updateList(item);
+ break;
+@@ -639,7 +640,7 @@
+ struct menu *menu;
+ enum prop_type type;
+
+- if (ev->key() == Key_Escape && mode != fullMode && mode != listMode) {
++ if (ev->key() == Qt::Key_Escape && mode != fullMode && mode != listMode) {
+ emit parentSelected();
+ ev->accept();
+ return;
+@@ -652,8 +653,8 @@
+ item = (ConfigItem*)i;
+
+ switch (ev->key()) {
+- case Key_Return:
+- case Key_Enter:
++ case Qt::Key_Return:
++ case Qt::Key_Enter:
+ if (item->goParent) {
+ emit parentSelected();
+ break;
+@@ -667,16 +668,16 @@
+ emit menuSelected(menu);
+ break;
+ }
+- case Key_Space:
++ case Qt::Key_Space:
+ changeValue(item);
+ break;
+- case Key_N:
++ case Qt::Key_N:
+ setValue(item, no);
+ break;
+- case Key_M:
++ case Qt::Key_M:
+ setValue(item, mod);
+ break;
+- case Key_Y:
++ case Qt::Key_Y:
+ setValue(item, yes);
+ break;
+ default:
+@@ -920,7 +921,7 @@
+ }
+
+ ConfigInfoView::ConfigInfoView(QWidget* parent, const char *name)
+- : Parent(parent, name), menu(0), sym(0)
++ : Parent(parent, name), sym(0), menu(0)
+ {
+ if (name) {
+ configSettings->beginGroup(name);
+@@ -1199,7 +1200,7 @@
+ layout1->addLayout(layout2);
+
+ split = new QSplitter(this);
+- split->setOrientation(QSplitter::Vertical);
++ split->setOrientation(Qt::Vertical);
+ list = new ConfigView(split, name);
+ list->list->mode = listMode;
+ info = new ConfigInfoView(split, name);
+@@ -1275,7 +1276,7 @@
+ int x, y, width, height;
+ char title[256];
+
+- QWidget *d = configApp->desktop();
++ QDesktopWidget *d = configApp->desktop();
+ snprintf(title, sizeof(title), _("Buildroot Configuration"));
+ setCaption(title);
+
+@@ -1289,14 +1290,14 @@
+ move(x, y);
+
+ split1 = new QSplitter(this);
+- split1->setOrientation(QSplitter::Horizontal);
++ split1->setOrientation(Qt::Horizontal);
+ setCentralWidget(split1);
+
+ menuView = new ConfigView(split1, "menu");
+ menuList = menuView->list;
+
+ split2 = new QSplitter(split1);
+- split2->setOrientation(QSplitter::Vertical);
++ split2->setOrientation(Qt::Vertical);
+
+ // create config tree
+ configView = new ConfigView(split2, "config");
+@@ -1314,18 +1315,18 @@
+ backAction = new QAction("Back", QPixmap(xpm_back), _("Back"), 0, this);
+ connect(backAction, SIGNAL(activated()), SLOT(goBack()));
+ backAction->setEnabled(FALSE);
+- QAction *quitAction = new QAction("Quit", _("&Quit"), CTRL+Key_Q, this);
++ QAction *quitAction = new QAction("Quit", _("&Quit"), Qt::CTRL + Qt::Key_Q, this);
+ connect(quitAction, SIGNAL(activated()), SLOT(close()));
+- QAction *loadAction = new QAction("Load", QPixmap(xpm_load), _("&Load"), CTRL+Key_L, this);
++ QAction *loadAction = new QAction("Load", QPixmap(xpm_load), _("&Load"), Qt::CTRL + Qt::Key_L, this);
+ connect(loadAction, SIGNAL(activated()), SLOT(loadConfig()));
+- saveAction = new QAction("Save", QPixmap(xpm_save), _("&Save"), CTRL+Key_S, this);
++ saveAction = new QAction("Save", QPixmap(xpm_save), _("&Save"), Qt::CTRL + Qt::Key_S, this);
+ connect(saveAction, SIGNAL(activated()), SLOT(saveConfig()));
+ conf_set_changed_callback(conf_changed);
+ // Set saveAction's initial state
+ conf_changed();
+ QAction *saveAsAction = new QAction("Save As...", _("Save &As..."), 0, this);
+ connect(saveAsAction, SIGNAL(activated()), SLOT(saveConfigAs()));
+- QAction *searchAction = new QAction("Find", _("&Find"), CTRL+Key_F, this);
++ QAction *searchAction = new QAction("Find", _("&Find"), Qt::CTRL + Qt::Key_F, this);
+ connect(searchAction, SIGNAL(activated()), SLOT(searchConfig()));
+ QAction *singleViewAction = new QAction("Single View", QPixmap(xpm_single_view), _("Single View"), 0, this);
+ connect(singleViewAction, SIGNAL(activated()), SLOT(showSingleView()));
+@@ -1446,7 +1447,7 @@
+
+ void ConfigMainWindow::loadConfig(void)
+ {
+- QString s = QFileDialog::getOpenFileName(".config", NULL, this);
++ QString s = QFileDialog::getOpenFileName(conf_get_configname(), NULL, this);
+ if (s.isNull())
+ return;
+ if (conf_read(QFile::encodeName(s)))
+@@ -1462,7 +1463,7 @@
+
+ void ConfigMainWindow::saveConfigAs(void)
+ {
+- QString s = QFileDialog::getSaveFileName(".config", NULL, this);
++ QString s = QFileDialog::getSaveFileName(conf_get_configname(), NULL, this);
+ if (s.isNull())
+ return;
+ if (conf_write(QFile::encodeName(s)))
+@@ -1523,6 +1524,8 @@
+ case fullMode:
+ list = configList;
+ break;
++ default:
++ break;
+ }
+
+ if (list) {
+@@ -1674,6 +1677,9 @@
+ case fullMode :
+ entry = "full";
+ break;
++
++ default:
++ break;
+ }
+ configSettings->writeEntry("/listMode", entry);
+