summaryrefslogtreecommitdiff
path: root/package/customize
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/customize
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/customize')
-rw-r--r--package/customize/Makefile.in3
-rw-r--r--package/customize/customize.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/customize/Makefile.in b/package/customize/Makefile.in
deleted file mode 100644
index 5a07dc777..000000000
--- a/package/customize/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_CUSTOMIZE)),y)
-TARGETS+=customize
-endif
diff --git a/package/customize/customize.mk b/package/customize/customize.mk
index d6c99407b..ed50f8f3a 100644
--- a/package/customize/customize.mk
+++ b/package/customize/customize.mk
@@ -7,3 +7,11 @@ CUST_DIR:=package/customize/source
customize:
-cp -af $(CUST_DIR)/* $(TARGET_DIR)/
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_CUSTOMIZE)),y)
+TARGETS+=customize
+endif