summaryrefslogtreecommitdiff
path: root/package/dbus
diff options
context:
space:
mode:
authorJohn Voltz <john.voltz@gmail.com>2008-03-12 14:51:32 +0000
committerJohn Voltz <john.voltz@gmail.com>2008-03-12 14:51:32 +0000
commitcd1d1fa6de53951d3d5543c6049eb00ff2ee2577 (patch)
treef4804d3e8e9c64854591dce802fc5fc9ca5d8ee3 /package/dbus
parent5d472aa583a92273c86a7e8c6f3eae7b52afd14d (diff)
fix dbus makefile to install with or without stripping
Diffstat (limited to 'package/dbus')
-rw-r--r--package/dbus/dbus.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/dbus/dbus.mk b/package/dbus/dbus.mk
index 2fcfbcb5f..aceb14206 100644
--- a/package/dbus/dbus.mk
+++ b/package/dbus/dbus.mk
@@ -66,8 +66,13 @@ $(STAGING_DIR)/usr/lib/libdbus-1.so: $(DBUS_DIR)/$(DBUS_BINARY)
$(TARGET_DIR)/$(DBUS_TARGET_BINARY): $(STAGING_DIR)/usr/lib/libdbus-1.so
mkdir -p $(TARGET_DIR)/var/run/dbus $(TARGET_DIR)/var/lib/dbus $(TARGET_DIR)/etc/init.d
+ifeq ($(BR2_STRIP_none),y)
+ $(MAKE) DESTDIR=$(TARGET_DIR) \
+ initdir=/etc/init.d -C $(DBUS_DIR) install
+else
$(MAKE) DESTDIR=$(TARGET_DIR) STRIPPROG='$(STRIPCMD)' \
initdir=/etc/init.d -C $(DBUS_DIR) install-strip
+endif
rm -rf $(TARGET_DIR)/usr/lib/dbus-1.0 \
$(TARGET_DIR)/usr/lib/libdbus-1.la \
$(TARGET_DIR)/usr/include/dbus-1.0 \