summaryrefslogtreecommitdiff
path: root/package/directfb
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2006-04-06 17:43:28 +0000
committerEric Andersen <andersen@codepoet.org>2006-04-06 17:43:28 +0000
commit4a01900a8d89d7df74d5467721b8a8f211b96b66 (patch)
tree77bdea02cc17c64010bca05ccf492505eaf142db /package/directfb
parentb607f5cdc3bc1c14ca3b049ea9f3b5de39883869 (diff)
tyler writes:
libdirectfb* is copied to target, but when the package builds it also builds libdirect* and libfusion*, which libdirectfb will call upon, but they are not copied along with libdirectfb.
Diffstat (limited to 'package/directfb')
-rw-r--r--package/directfb/directfb.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/package/directfb/directfb.mk b/package/directfb/directfb.mk
index 51062a865..a39f92cb8 100644
--- a/package/directfb/directfb.mk
+++ b/package/directfb/directfb.mk
@@ -52,9 +52,12 @@ $(STAGING_DIR)/usr/lib/libdirectfb.so: $(DIRECTFB_DIR)/.compiled
touch -c $(STAGING_DIR)/lib/libdirectfb.so
$(TARGET_DIR)/usr/lib/libdirectfb.so: $(STAGING_DIR)/usr/lib/libdirectfb.so
- cp -dpf $(STAGING_DIR)/usr/lib/libdirectfb* $(TARGET_DIR)/usr/lib/
+ cp -dpf $(STAGING_DIR)/usr/lib/libdirect* $(STAGING_DIR)/usr/lib/libfusion* $(TARGET_DIR)/usr/lib/
cp -rdpf $(STAGING_DIR)/usr/lib/directfb-$(DIRECTFB_VERSION) $(TARGET_DIR)/usr/lib/
- -$(STRIP) --strip-unneeded $(TARGET_DIR)/usr/lib/libdirectfb.so
+ -$(STRIP) --strip-unneeded \
+ $(TARGET_DIR)/usr/lib/libdirectfb.so \
+ $(TARGET_DIR)/usr/lib/libdirect.so \
+ $(TARGET_DIR)/usr/lib/libfusion.so
directfb: uclibc jpeg libpng freetype libsysfs $(TARGET_DIR)/usr/lib/libdirectfb.so