summaryrefslogtreecommitdiff
path: root/package/efl
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-01-30 23:22:51 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-30 23:22:51 +0100
commitcf96a9bec0c2ad40b820c6f465c2ac17d3bc4e03 (patch)
tree94b12d76e564b9dd6a6a7ecd8daf484c7fd90f87 /package/efl
parent4aadcac1684e4af54baa7e42b5e0fb73aa4b33b3 (diff)
libevas: really fix x86 cpu optimization options handling
Disable all options by default, and only enable the applicable one. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/efl')
-rw-r--r--package/efl/libevas/libevas.mk9
1 files changed, 3 insertions, 6 deletions
diff --git a/package/efl/libevas/libevas.mk b/package/efl/libevas/libevas.mk
index 6ad1126e7..acb2f4bd9 100644
--- a/package/efl/libevas/libevas.mk
+++ b/package/efl/libevas/libevas.mk
@@ -94,6 +94,9 @@ endif
# code options
ifeq ($(BR2_i386)$(BR2_x86_64),y)
+# defaults
+LIBEVAS_CONF_OPT += --disable-cpu-mmx --disable-cpu-sse --disable-cpu-sse3
+
# enable if cpu variant has mmx support
ifneq ($(BR2_x86_i386)$(BR2_x86_i486)$(BR2_x86_i586)$(BR2_x86_i686)$(BR2_x86_pentiumpro)$(BR2_x86_geode),y)
LIBEVAS_CONF_OPT += --enable-cpu-mmx
@@ -103,14 +106,8 @@ LIBEVAS_CONF_OPT += --enable-cpu-sse
ifneq ($(BR2_x86_pentium3)$(BR2_x86_pentium4)$(BR2_x86_prescott)$(BR2_x86_athlon_4)$(BR2_x86_opteron)$(BR2_x86_c32)$(BR2_x86_64_opteron),y)
LIBEVAS_CONF_OPT += --enable-cpu-sse3
-else
-LIBEVAS_CONF_OPT += --disable-cpu-sse3
endif # sse3
-else
-LIBEVAS_CONF_OPT += --disable-cpu-sse
endif # sse
-else
-LIBEVAS_CONF_OPT += --disable-cpu-mmx
endif # mmx
endif # x86