summaryrefslogtreecommitdiff
path: root/package/games/magiccube4d
diff options
context:
space:
mode:
authorDaniel Laird <danieljlaird@hotmail.com>2008-08-29 13:27:37 +0000
committerDaniel Laird <danieljlaird@hotmail.com>2008-08-29 13:27:37 +0000
commit1b5c1e7bdbdf496078a8556c2906919432f60d52 (patch)
tree0eb0f404efb85594de1dfb4e3d31856d04808faf /package/games/magiccube4d
parent022b95d6ef7b303f6fbd48c220001674eec4717a (diff)
games: Move all games into games subdir
Moved all games into a subdir called games and then updated makefiles as necessary. If not one objects to this one then I will probably do the same for audio next. Daniel Laird
Diffstat (limited to 'package/games/magiccube4d')
-rw-r--r--package/games/magiccube4d/Config.in6
-rw-r--r--package/games/magiccube4d/magiccube4d-2_2-add-installer.patch13
-rw-r--r--package/games/magiccube4d/magiccube4d-2_2-no-warn-err.patch11
-rw-r--r--package/games/magiccube4d/magiccube4d.mk16
4 files changed, 46 insertions, 0 deletions
diff --git a/package/games/magiccube4d/Config.in b/package/games/magiccube4d/Config.in
new file mode 100644
index 000000000..ba4bceb01
--- /dev/null
+++ b/package/games/magiccube4d/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_MAGICCUBE4D
+ bool "magiccube4d"
+ help
+ Another rubiks cube-like game in 4D
+
+ http://avr32linux.org/twiki/bin/viewfile/Main
diff --git a/package/games/magiccube4d/magiccube4d-2_2-add-installer.patch b/package/games/magiccube4d/magiccube4d-2_2-add-installer.patch
new file mode 100644
index 000000000..afe543ba3
--- /dev/null
+++ b/package/games/magiccube4d/magiccube4d-2_2-add-installer.patch
@@ -0,0 +1,13 @@
+--- a/Makefile.in 2000-04-01 22:45:36.000000000 -0500
++++ b/Makefile.in 2008-02-29 13:18:24.000000000 -0500
+@@ -126,6 +126,10 @@ tgz: $(SRCTGZ)
+
+ bindist: $(BINTGZ)
+
++install :
++ mkdir -p $(GAMESDIR)
++ install -c magiccube4d $(GAMESDIR)
++
+ rpm: $(SRCTGZ)
+ rpm -ta $(SRCTGZ)
+
diff --git a/package/games/magiccube4d/magiccube4d-2_2-no-warn-err.patch b/package/games/magiccube4d/magiccube4d-2_2-no-warn-err.patch
new file mode 100644
index 000000000..8bbc483ab
--- /dev/null
+++ b/package/games/magiccube4d/magiccube4d-2_2-no-warn-err.patch
@@ -0,0 +1,11 @@
+--- a/configure 2000-02-10 23:19:34.000000000 -0500
++++ b/configure 2008-02-29 13:12:33.000000000 -0500
+@@ -686,7 +686,7 @@ fi
+
+
+ if test "$GXX" = "yes" ; then
+- WFLAGS="$WFLAGS -pedantic -Wall -W -Wunused -Werror"
++ WFLAGS="$WFLAGS -pedantic -Wall -W -Wunused"
+ fi
+ echo $ac_n "checking how to run the C preprocessor""... $ac_c" 1>&6
+ echo "configure:693: checking how to run the C preprocessor" >&5
diff --git a/package/games/magiccube4d/magiccube4d.mk b/package/games/magiccube4d/magiccube4d.mk
new file mode 100644
index 000000000..fa36be289
--- /dev/null
+++ b/package/games/magiccube4d/magiccube4d.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# magiccube4d
+#
+#############################################################
+MAGICCUBE4D_VERSION = 2_2
+MAGICCUBE4D_SOURCE = magiccube4d-src-$(MAGICCUBE4D_VERSION).tar.gz
+MAGICCUBE4D_SITE = http://avr32linux.org/twiki/pub/Main/MagicCube4D
+MAGICCUBE4D_INSTALL_STAGING = NO
+MAGICCUBE4D_INSTALL_TARGET = YES
+MAGICCUBE4D_INSTALL_TARGET_OPT = GAMESDIR=$(TARGET_DIR)/usr/games install
+
+MAGICCUBE4D_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package/games,magiccube4d))
+