summaryrefslogtreecommitdiff
path: root/package/grep/grep.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-07-23 10:35:53 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-07-23 10:35:53 +0000
commit9a1526d7d9474a5b3a43f0c0e453f431428fafcc (patch)
treef9ec4f754f0525f1c71cb6b4450d6e7e5f68e85d /package/grep/grep.mk
parenta649ed0da05c572d1082f91e3abe3ab6fe3a6c09 (diff)
grep: gettext/libintl is only required if locale is enabled
Diffstat (limited to 'package/grep/grep.mk')
-rw-r--r--package/grep/grep.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index c12b1df1c..0e99698e0 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -11,6 +11,10 @@ GNUGREP_CAT:=$(ZCAT)
GNUGREP_BINARY:=src/grep
GNUGREP_TARGET_BINARY:=bin/grep
+ifeq ($(BR2_ENABLE_LOCALE),y)
+GNUGREP_EXTRA_DEPS:=gettext libintl
+endif
+
$(DL_DIR)/$(GNUGREP_SOURCE):
$(WGET) -P $(DL_DIR) $(GNUGREP_SITE)/$(GNUGREP_SOURCE)
@@ -65,7 +69,7 @@ grep-target_binary: $(GNUGREP_DIR)/$(GNUGREP_BINARY)
cp -a $(GNUGREP_DIR)/src/grep $(GNUGREP_DIR)/src/egrep \
$(GNUGREP_DIR)/src/fgrep $(TARGET_DIR)/bin/; fi
-grep: uclibc gettext libintl grep-target_binary
+grep: uclibc $(GNUGREP_EXTRA_DEPS) grep-target_binary
grep-clean:
$(MAKE) DESTDIR=$(TARGET_DIR) -C $(GNUGREP_DIR) uninstall