summaryrefslogtreecommitdiff
path: root/package/hostap
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/hostap
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/hostap')
-rw-r--r--package/hostap/Makefile.in3
-rw-r--r--package/hostap/hostap.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/hostap/Makefile.in b/package/hostap/Makefile.in
deleted file mode 100644
index 2b65d710f..000000000
--- a/package/hostap/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_HOSTAP)),y)
-TARGETS+=hostap
-endif
diff --git a/package/hostap/hostap.mk b/package/hostap/hostap.mk
index 3583f7eb8..5bb79fe2f 100644
--- a/package/hostap/hostap.mk
+++ b/package/hostap/hostap.mk
@@ -51,3 +51,11 @@ hostap-clean:
hostap-dirclean:
rm -rf $(HOSTAP_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_HOSTAP)),y)
+TARGETS+=hostap
+endif