summaryrefslogtreecommitdiff
path: root/package/hotplug
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/hotplug
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/hotplug')
-rw-r--r--package/hotplug/Makefile.in3
-rw-r--r--package/hotplug/hotplug.mk8
2 files changed, 8 insertions, 3 deletions
diff --git a/package/hotplug/Makefile.in b/package/hotplug/Makefile.in
deleted file mode 100644
index 69b1f4a3d..000000000
--- a/package/hotplug/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-ifeq ($(strip $(BR2_PACKAGE_HOTPLUG)),y)
-TARGETS+=hotplug
-endif
diff --git a/package/hotplug/hotplug.mk b/package/hotplug/hotplug.mk
index 293bf6228..74ffc8603 100644
--- a/package/hotplug/hotplug.mk
+++ b/package/hotplug/hotplug.mk
@@ -36,3 +36,11 @@ hotplug-clean:
hotplug-dirclean:
rm -rf $(HOTPLUG_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_HOTPLUG)),y)
+TARGETS+=hotplug
+endif