summaryrefslogtreecommitdiff
path: root/package/iptables/iptables.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:25:32 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:36:00 +0200
commit1860bdae8cdf4f9eb7097fd7e5ed7e9c0c5b6a75 (patch)
treeb3b4fb6139799602676e100126c19055b18ac7f0 /package/iptables/iptables.mk
parentc106fdbd100f36fe3329360af8f656566937f00a (diff)
parentae2be8dbc36293d8243baf2b13ad17a47738d6d3 (diff)
Merge branch 'for-2010.11/remove-oldstyle-hooks' of git://git.busybox.net/~tpetazzoni/git/buildroot
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/iptables/iptables.mk')
-rw-r--r--package/iptables/iptables.mk28
1 files changed, 19 insertions, 9 deletions
diff --git a/package/iptables/iptables.mk b/package/iptables/iptables.mk
index 0b7dae181..21146bce6 100644
--- a/package/iptables/iptables.mk
+++ b/package/iptables/iptables.mk
@@ -16,24 +16,34 @@ endif
IPTABLES_AUTORECONF = YES
IPTABLES_LIBTOOL_PATCH = NO
-$(eval $(call AUTOTARGETS,package,iptables))
-
-$(IPTABLES_HOOK_POST_INSTALL): $(IPTABLES_TARGET_INSTALL_TARGET)
+define IPTABLES_TARGET_SYMLINK_CREATE
ln -sf iptables-multi $(TARGET_DIR)/usr/sbin/iptables
ln -sf iptables-multi $(TARGET_DIR)/usr/sbin/iptables-save
ln -sf iptables-multi $(TARGET_DIR)/usr/sbin/iptables-restore
-ifeq ($(BR2_INET_IPV6),y)
+endef
+
+define IPTABLES_TARGET_IPV6_SYMLINK_CREATE
ln -sf ip6tables-multi $(TARGET_DIR)/usr/sbin/ip6tables
ln -sf ip6tables-multi $(TARGET_DIR)/usr/sbin/ip6tables-save
ln -sf ip6tables-multi $(TARGET_DIR)/usr/sbin/ip6tables-restore
-else
+endef
+
+define IPTABLES_TARGET_IPV6_REMOVE
rm -f $(TARGET_DIR)/usr/lib/libip6tc.*
+endef
+
+IPTABLES_POST_INSTALL_TARGET_HOOKS += IPTABLES_TARGET_SYMLINK_CREATE
+
+ifeq ($(BR2_INET_IPV6),y)
+IPTABLES_POST_INSTALL_TARGET_HOOKS += IPTABLES_TARGET_IPV6_SYMLINK_CREATE
+else
+IPTABLES_POST_INSTALL_TARGET_HOOKS += IPTABLES_TARGET_IPV6_REMOVE
endif
- touch $@
-$(IPTABLES_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
+define IPTABLES_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/bin/iptables-xml
rm -f $(TARGET_DIR)/usr/sbin/iptables* $(TARGET_DIR)/usr/sbin/ip6tables*
rm -rf $(TARGET_DIR)/usr/lib/xtables
- rm -f $(IPTABLES_TARGET_INSTALL_TARGET) $(IPTABLES_HOOK_POST_INSTALL)
+endef
+
+$(eval $(call AUTOTARGETS,package,iptables))