summaryrefslogtreecommitdiff
path: root/package/iptables
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
committerEric Andersen <andersen@codepoet.org>2004-10-09 01:24:28 +0000
commit73f7be82904f487d167493e76b415fbe5b5f8c5a (patch)
tree8d9acaf4414892fad533fd92ebfc7e65a2ad2785 /package/iptables
parent0b5ad783691ef6fa1285c8d7858a51c425a8b38d (diff)
Remove the old 'make' directory, and populate the new 'package'
directory.
Diffstat (limited to 'package/iptables')
-rw-r--r--package/iptables/iptables.mk51
1 files changed, 51 insertions, 0 deletions
diff --git a/package/iptables/iptables.mk b/package/iptables/iptables.mk
new file mode 100644
index 000000000..2d4ef43b5
--- /dev/null
+++ b/package/iptables/iptables.mk
@@ -0,0 +1,51 @@
+#############################################################
+#
+# iptables
+#
+#############################################################
+IPTABLES_SOURCE_URL=http://www.netfilter.org/files
+IPTABLES_SOURCE=iptables-1.2.9.tar.bz2
+IPTABLES_BUILD_DIR=$(BUILD_DIR)/iptables-1.2.9
+
+$(DL_DIR)/$(IPTABLES_SOURCE):
+ $(WGET) -P $(DL_DIR) $(IPTABLES_SOURCE_URL)/$(IPTABLES_SOURCE)
+
+$(IPTABLES_BUILD_DIR)/.unpacked: $(DL_DIR)/$(IPTABLES_SOURCE)
+ bzcat $(DL_DIR)/$(IPTABLES_SOURCE) | tar -C $(BUILD_DIR) -xvf -
+ touch $(IPTABLES_BUILD_DIR)/.unpacked
+
+$(IPTABLES_BUILD_DIR)/.configured: $(IPTABLES_BUILD_DIR)/.unpacked
+ # Allow patches. Needed for openwrt for instance.
+ $(SOURCE_DIR)/patch-kernel.sh $(IPTABLES_BUILD_DIR) $(SOURCE_DIR) iptables-\*.patch
+ #
+ $(SED) "s;\[ -f /usr/include/netinet/ip6.h \];grep -q '__UCLIBC_HAS_IPV6__ 1' \
+ $(BUILD_DIR)/uClibc/include/bits/uClibc_config.h;" $(IPTABLES_BUILD_DIR)/Makefile
+ touch $(IPTABLES_BUILD_DIR)/.configured
+
+$(IPTABLES_BUILD_DIR)/iptables: $(IPTABLES_BUILD_DIR)/.configured
+ $(TARGET_CONFIGURE_OPTS) \
+ $(MAKE) -C $(IPTABLES_BUILD_DIR) \
+ KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr \
+ CC=$(TARGET_CC) COPT_FLAGS="$(TARGET_CFLAGS)"
+
+$(TARGET_DIR)/sbin/iptables: $(IPTABLES_BUILD_DIR)/iptables
+ $(TARGET_CONFIGURE_OPTS) \
+ $(MAKE) -C $(IPTABLES_BUILD_DIR) \
+ KERNEL_DIR=$(LINUX_DIR) PREFIX=/usr \
+ CC=$(TARGET_CC) COPT_FLAGS="$(TARGET_CFLAGS)" \
+ DESTDIR=$(TARGET_DIR) install
+ $(STRIP) $(TARGET_DIR)/usr/sbin/iptables*
+ $(STRIP) $(TARGET_DIR)/usr/lib/iptables/*.so
+ rm -rf $(TARGET_DIR)/usr/man
+
+iptables: linux $(TARGET_DIR)/sbin/iptables
+
+iptables-source: $(DL_DIR)/$(IPTABLES_SOURCE)
+
+iptables-clean:
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(IPTABLES_BUILD_DIR) uninstall
+ -$(MAKE) -C $(IPTABLES_BUILD_DIR) clean
+
+iptables-dirclean:
+ rm -rf $(IPTABLES_BUILD_DIR)
+