summaryrefslogtreecommitdiff
path: root/package/kexec/kexec.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:25:32 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:36:00 +0200
commit1860bdae8cdf4f9eb7097fd7e5ed7e9c0c5b6a75 (patch)
treeb3b4fb6139799602676e100126c19055b18ac7f0 /package/kexec/kexec.mk
parentc106fdbd100f36fe3329360af8f656566937f00a (diff)
parentae2be8dbc36293d8243baf2b13ad17a47738d6d3 (diff)
Merge branch 'for-2010.11/remove-oldstyle-hooks' of git://git.busybox.net/~tpetazzoni/git/buildroot
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/kexec/kexec.mk')
-rw-r--r--package/kexec/kexec.mk14
1 files changed, 6 insertions, 8 deletions
diff --git a/package/kexec/kexec.mk b/package/kexec/kexec.mk
index 436788517..5081ee81a 100644
--- a/package/kexec/kexec.mk
+++ b/package/kexec/kexec.mk
@@ -16,12 +16,10 @@ else
KEXEC_CONF_OPT += --without-zlib
endif
-$(eval $(call AUTOTARGETS,package,kexec))
-
-$(KEXEC_HOOK_POST_INSTALL): $(KEXEC_TARGET_INSTALL_TARGET)
-ifneq ($(BR2_ENABLE_DEBUG),y)
- $(STRIPCMD) $(STRIP_STRIP_ALL) $(TARGET_DIR)/usr/sbin/kexec
- $(STRIPCMD) $(STRIP_STRIP_ALL) $(TARGET_DIR)/usr/sbin/kdump
-endif
+define KEXEC_REMOVE_LIB_TOOLS
rm -rf $(TARGET_DIR)/usr/lib/kexec-tools
- touch $@
+endef
+
+KEXEC_POST_INSTALL_TARGET_HOOKS += KEXEC_REMOVE_LIB_TOOLS
+
+$(eval $(call AUTOTARGETS,package,kexec))