summaryrefslogtreecommitdiff
path: root/package/libconfuse
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-09-22 08:11:05 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-09-22 08:11:05 +0000
commit0e23e6bdf131d2b1be22c02d307730048de3d7ed (patch)
treeafefc8f515e2c68a7b4c66aa5ab4887ee2a8d9d1 /package/libconfuse
parent681f7022fa5e54ddd7fe2096763515efe6519dec (diff)
package: add libconfuse - A library for parsing configuration files
Diffstat (limited to 'package/libconfuse')
-rw-r--r--package/libconfuse/Config.in11
-rw-r--r--package/libconfuse/libconfuse.mk18
2 files changed, 29 insertions, 0 deletions
diff --git a/package/libconfuse/Config.in b/package/libconfuse/Config.in
new file mode 100644
index 000000000..e123dab48
--- /dev/null
+++ b/package/libconfuse/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBCONFUSE
+ bool "libconfuse"
+ help
+ LibConfuse is a configuration file parser library written in
+ C. It supports sections and (lists of) values (strings,
+ integers, floats, booleans or other sections), as well as some
+ other features (such as single/double-quoted strings,
+ environment variable expansion, functions and nested include
+ statements.
+
+ http://www.nongnu.org/confuse/
diff --git a/package/libconfuse/libconfuse.mk b/package/libconfuse/libconfuse.mk
new file mode 100644
index 000000000..f6220dbfc
--- /dev/null
+++ b/package/libconfuse/libconfuse.mk
@@ -0,0 +1,18 @@
+#############################################################
+#
+# libconfuse
+#
+#############################################################
+LIBCONFUSE_VERSION:=2.6
+LIBCONFUSE_SOURCE:=confuse-$(LIBCONFUSE_VERSION).tar.gz
+LIBCONFUSE_SITE:=http://bzero.se/confuse/
+LIBCONFUSE_AUTORECONF:=NO
+LIBCONFUSE_INSTALL_STAGING:=YES
+LIBCONFUSE_INSTALL_TARGET:=YES
+LIBCONFUSE_INSTALL_TARGET_OPT:=DESTDIR=$(TARGET_DIR) install-strip
+
+LIBCONFUSE_CONF_OPT:=--enable-shared --disable-rpath $(DISABLE_NLS)
+
+LIBCONFUSE_DEPENDENCIES = uclibc
+
+$(eval $(call AUTOTARGETS,package,libconfuse))