summaryrefslogtreecommitdiff
path: root/package/libdnet/libdnet-002-python-makefile.patch
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-06-21 00:01:34 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-06-21 00:01:34 +0200
commit21438ec500ca0962fa0f2572a6212786674d5e32 (patch)
tree980f63ece256639def497b0e97f29e2d12935148 /package/libdnet/libdnet-002-python-makefile.patch
parent377b2785c136e7439ac4f4a6e4509bc5c9fe3015 (diff)
libdnet: fix python module build
Ensure the correct compiler/linker flags are used. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libdnet/libdnet-002-python-makefile.patch')
-rw-r--r--package/libdnet/libdnet-002-python-makefile.patch12
1 files changed, 9 insertions, 3 deletions
diff --git a/package/libdnet/libdnet-002-python-makefile.patch b/package/libdnet/libdnet-002-python-makefile.patch
index 4c8729ddc..fb41e43e3 100644
--- a/package/libdnet/libdnet-002-python-makefile.patch
+++ b/package/libdnet/libdnet-002-python-makefile.patch
@@ -1,10 +1,16 @@
---- a/python/Makefile.am 2006-01-15 18:08:23.000000000 +1100
-+++ b/python/Makefile.am 2008-09-04 15:25:52.000000000 +1000
+---
+ python/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
+
+Index: libdnet-1.11/python/Makefile.am
+===================================================================
+--- libdnet-1.11.orig/python/Makefile.am
++++ libdnet-1.11/python/Makefile.am
@@ -11,6 +11,7 @@
pyrexc $(srcdir)/dnet.pyx
python-build: $(srcdir)/dnet.c
-+ CC="$(CC)" LDSHARED="$(CC) -shared" $(PYTHON) setup.py build_ext -I$(PYINCDIR)
++ CC="$(CC)" LDSHARED="$(CC) -shared" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" $(PYTHON) setup.py build_ext -I$(PYINCDIR) -L$(PYLIBDIR)
$(PYTHON) setup.py build
touch python-build