summaryrefslogtreecommitdiff
path: root/package/liboil/liboil-vfp.patch
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-18 10:51:53 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-18 10:51:53 +0000
commit6da70de5034ae3933c6d072378a8860078686200 (patch)
tree13db89b68591f78d408d5af49a0e88f0cba94f22 /package/liboil/liboil-vfp.patch
parentc86f23b7708cb7eeba91a2764210277c78143dca (diff)
The liboil Makefile will use "-mcpu=vfp" when building for ARM.
The VFP is only available for a few ARM CPUs at the moment, so this breaks the liboil build. A patch is available upstream which only enables "-mfpu=vfp" if "--enable-vfp" is given to "configure". Autotools needs to be run for liboil for this to take effect. A new configuration BR2_VFP_FLOAT is added to allow enabling vfp. If this is "yes", then "-mfpu=vfp" is added to CFLAGS.
Diffstat (limited to 'package/liboil/liboil-vfp.patch')
-rw-r--r--package/liboil/liboil-vfp.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/liboil/liboil-vfp.patch b/package/liboil/liboil-vfp.patch
new file mode 100644
index 000000000..815c9bb9a
--- /dev/null
+++ b/package/liboil/liboil-vfp.patch
@@ -0,0 +1,16 @@
+diff --git a/configure.ac b/configure.ac
+index 06a0ac9..b8d1640 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -158,7 +158,10 @@ if test x$HAVE_GCC_ASM = xyes -a x$HAVE_POWERPC = xyes ; then
+ true)
+ fi
+
+-if test x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes ; then
++AC_ARG_ENABLE(vfp,
++ AC_HELP_STRING([--enable-vfp],[compile with Vector Floating-point unit support]),
++ enable_vfp=$enableval,enable_vfp=yes)
++if test "x$enable-vfp" = xyes -a x$HAVE_GCC_ASM = xyes -a x$HAVE_ARM = xyes; then
+ AS_COMPILER_FLAG(["-Wa,-mfpu=vfp"],
+ [LIBOIL_CFLAGS="$LIBOIL_CFLAGS -mfpu=vfp"],
+ true)