summaryrefslogtreecommitdiff
path: root/package/liboil
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2008-12-03 09:02:46 +0000
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2008-12-03 09:02:46 +0000
commite5d9702dfd020fccb461844b549f718ae629aacf (patch)
tree7e8b4352788a89db0b0f82e0f09690632e648403 /package/liboil
parentbe5be0ec5abb6cf88d24d9b17329a206938006ec (diff)
Liboil is a library of simple functions that are optimized for various
CPUs. It is required by various GStreamer plugins. Signed-off-by: Markus Heidelberg <markus.heidelberg@web.de> Modifications by Thomas Petazzoni: - Remove the glib2 dependency, which is only necessary to build a few examples. If glib2 is enabled in the configuration, then we still depend on it in order to build the examples, but that's just pedantic, not so useful. - Remove the oil-bugreport program installed to the target by install-strip. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/liboil')
-rw-r--r--package/liboil/Config.in6
-rw-r--r--package/liboil/liboil.mk43
2 files changed, 49 insertions, 0 deletions
diff --git a/package/liboil/Config.in b/package/liboil/Config.in
new file mode 100644
index 000000000..0acbbfc13
--- /dev/null
+++ b/package/liboil/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBOIL
+ bool "liboil"
+ help
+ Library of simple functions that are optimized for various CPUs.
+
+ http://liboil.freedesktop.org/
diff --git a/package/liboil/liboil.mk b/package/liboil/liboil.mk
new file mode 100644
index 000000000..6e80ed60e
--- /dev/null
+++ b/package/liboil/liboil.mk
@@ -0,0 +1,43 @@
+#############################################################
+#
+# liboil
+#
+#############################################################
+LIBOIL_VERSION = 0.3.15
+LIBOIL_SOURCE = liboil-$(LIBOIL_VERSION).tar.gz
+LIBOIL_SITE = http://liboil.freedesktop.org/download
+LIBOIL_AUTORECONF = NO
+LIBOIL_INSTALL_STAGING = YES
+LIBOIL_INSTALL_TARGET = YES
+
+# Checking if unaligned memory access works correctly cannot be done when cross
+# compiling. For the following architectures there is no information available
+# in the configure script.
+ifeq ($(BR2_avr32),y)
+LIBOIL_CONF_ENV = as_cv_unaligned_access=no
+endif
+ifeq ($(BR2_cris),y)
+LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
+endif
+ifeq ($(BR2_nios2),y)
+LIBOIL_CONF_ENV = as_cv_unaligned_access=no
+endif
+ifeq ($(BR2_s390),y)
+LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
+endif
+ifeq ($(BR2_x86_64),y)
+LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
+LIBOIL_GLIB_DEP = libglib2
+endif
+
+LIBOIL_DEPENDENCIES = uclibc $(LIBOIL_GLIB_DEP)
+
+$(eval $(call AUTOTARGETS,package,liboil))
+
+$(LIBOIL_HOOK_POST_INSTALL):
+ # Remove useless bugreport program from the target
+ rm -f $(TARGET_DIR)/usr/bin/oil-bugreport
+ touch $@ \ No newline at end of file