summaryrefslogtreecommitdiff
path: root/package/libpng/libpng.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/libpng/libpng.mk
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/libpng/libpng.mk')
-rw-r--r--package/libpng/libpng.mk44
1 files changed, 22 insertions, 22 deletions
diff --git a/package/libpng/libpng.mk b/package/libpng/libpng.mk
index df1470aa6..88f19dfa7 100644
--- a/package/libpng/libpng.mk
+++ b/package/libpng/libpng.mk
@@ -38,22 +38,30 @@ $(LIBPNG_DIR)/.unpacked: $(DL_DIR)/$(LIBPNG_SOURCE)
$(LIBPNG_DIR)/.configured: $(LIBPNG_DIR)/.unpacked
(cd $(LIBPNG_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) CC_FOR_BUILD="$(HOSTCC)" \
+ $(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
- ./configure \
ac_cv_func_memcmp_working=yes \
ac_cv_have_decl_malloc=yes \
gl_cv_func_malloc_0_nonnull=yes \
ac_cv_func_malloc_0_nonnull=yes \
ac_cv_func_calloc_0_nonnull=yes \
ac_cv_func_realloc_0_nonnull=yes \
+ ./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
- --prefix=$(STAGING_DIR) \
- --exec_prefix=$(STAGING_DIR) \
- --libdir=$(STAGING_DIR)/lib \
- --includedir=$(STAGING_DIR)/include \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --includedir=/include \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
--without-libpng-compat \
--without-x \
);
@@ -64,28 +72,20 @@ $(LIBPNG_DIR)/.compiled: $(LIBPNG_DIR)/.configured
touch $(LIBPNG_DIR)/.compiled
$(STAGING_DIR)/lib/libpng.so: $(LIBPNG_DIR)/.compiled
- $(MAKE) prefix=$(STAGING_DIR) \
- exec_prefix=$(STAGING_DIR) \
- bindir=$(STAGING_DIR)/bin \
- sbindir=$(STAGING_DIR)/sbin \
- libexecdir=$(STAGING_DIR)/libexec \
- datadir=$(STAGING_DIR)/share \
- sysconfdir=$(STAGING_DIR)/etc \
- sharedstatedir=$(STAGING_DIR)/com \
- localstatedir=$(STAGING_DIR)/var \
- libdir=$(STAGING_DIR)/lib \
- includedir=$(STAGING_DIR)/include \
- oldincludedir=$(STAGING_DIR)/include \
- infodir=$(STAGING_DIR)/info \
- mandir=$(STAGING_DIR)/man \
- -C $(LIBPNG_DIR) install;
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBPNG_DIR) install;
+ $(SED) "s,^libdir=.*,libdir=\'$(STAGING_DIR)/lib\',g" $(STAGING_DIR)/lib/libpng12.la
+ $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)\',g" \
+ -e "s,^exec_prefix=.*,exec_prefix=\'$(STAGING_DIR)/usr\',g" \
+ -e "s,^includedir=.*,includedir=\'$(STAGING_DIR)/include/libpng12\',g" \
+ "s,^libdir=.*,libdir=\'$(STAGING_DIR)/lib\',g" \
+ $(STAGING_DIR)/usr/bin/libpng12-config
touch -c $(STAGING_DIR)/lib/libpng.so
$(TARGET_DIR)/usr/lib/libpng.so: $(STAGING_DIR)/lib/libpng.so
cp -dpf $(STAGING_DIR)/lib/libpng*.so* $(TARGET_DIR)/usr/lib/
-$(STRIP) --strip-unneeded $(TARGET_DIR)/usr/lib/libpng.so
-png libpng: uclibc zlib $(TARGET_DIR)/usr/lib/libpng.so
+png libpng: uclibc zlib pkgconfig $(TARGET_DIR)/usr/lib/libpng.so
libpng-clean:
-$(MAKE) -C $(LIBPNG_DIR) clean