summaryrefslogtreecommitdiff
path: root/package/libpng/libpng.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/libpng/libpng.mk
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/libpng/libpng.mk')
-rw-r--r--package/libpng/libpng.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/libpng/libpng.mk b/package/libpng/libpng.mk
index 4e3bb8e9f..55862e17b 100644
--- a/package/libpng/libpng.mk
+++ b/package/libpng/libpng.mk
@@ -69,3 +69,11 @@ libpng: uclibc zlib $(TARGET_DIR)/usr/lib/libpng.so
libpng-clean:
-$(MAKE) -C $(LIBPNG_DIR) clean
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_LIBPNG)),y)
+TARGETS+=libpng
+endif