summaryrefslogtreecommitdiff
path: root/package/libroxml/libroxml.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-07-13 12:44:42 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-13 12:57:54 +0200
commitb28de60c24ad4bef4ff7a6ad51cbb6e79906c868 (patch)
tree39bb6bfc5ff2ef5fb9afafd864cbc3cac4009b9b /package/libroxml/libroxml.mk
parentb51b664727458235460ed3c5429b8d44215b9446 (diff)
package: add libroxml
Closes #3595 Based on patch by Tristan Lelong <tristan.lelong@blunderer.org>. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/libroxml/libroxml.mk')
-rw-r--r--package/libroxml/libroxml.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/package/libroxml/libroxml.mk b/package/libroxml/libroxml.mk
new file mode 100644
index 000000000..bf067dfd7
--- /dev/null
+++ b/package/libroxml/libroxml.mk
@@ -0,0 +1,33 @@
+#
+# libroxml
+#
+
+LIBROXML_VERSION = 2.0.3
+LIBROXML_SITE = http://libroxml.googlecode.com/files
+LIBROXML_INSTALL_STAGING = YES
+
+define LIBROXML_BUILD_CMDS
+ $(MAKE) $(TARGET_CONFIGURE_OPTS) OPTIM= -C $(@D) V=1 all
+endef
+
+define LIBROXML_INSTALL_STAGING_CMDS
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(@D) install
+endef
+
+define LIBROXML_INSTALL_TARGET_CMDS
+ $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) install
+endef
+
+define LIBROXML_UNINSTALL_STAGING_CMDS
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(@D) uninstall
+endef
+
+define LIBROXML_UNINSTALL_TARGET_CMDS
+ $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) uninstall
+endef
+
+define LIBROXML_CLEAN_CMDS
+ -$(MAKE) -C $(@D) clean
+endef
+
+$(eval $(call GENTARGETS,package,libroxml))