summaryrefslogtreecommitdiff
path: root/package/lighttpd
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2008-07-05 08:20:34 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2008-07-05 08:20:34 +0000
commite156f34a4a5bb828f2309ece2af95750a98f9d0e (patch)
treecb113d71201e911f3abea8363c8de41ebc598209 /package/lighttpd
parent46ca47e436cf733e057ddf8e20b41e9f42a733a3 (diff)
[0002974] add support for zlib and bzip2 in lighttpd, use alphabetical order for lighttpd config
Diffstat (limited to 'package/lighttpd')
-rw-r--r--package/lighttpd/Config.in18
-rw-r--r--package/lighttpd/lighttpd.mk14
2 files changed, 31 insertions, 1 deletions
diff --git a/package/lighttpd/Config.in b/package/lighttpd/Config.in
index 7db9b2d3e..7967022a3 100644
--- a/package/lighttpd/Config.in
+++ b/package/lighttpd/Config.in
@@ -16,13 +16,29 @@ if BR2_PACKAGE_LIGHTTPD
menu "lighttpd packages"
config BR2_PACKAGE_LIGHTTPD_OPENSSL
- bool "openssl"
+ bool "lighttpd openssl support"
default y
depends on BR2_PACKAGE_LIGHTTPD
select BR2_PACKAGE_OPENSSL
help
Enable OpenSSL support for lighttpd.
+config BR2_PACKAGE_LIGHTTPD_ZLIB
+ bool "lighttpd zlib support"
+ default n
+ depends on BR2_PACKAGE_LIGHTTPD
+ select BR2_PACKAGE_ZLIB
+ help
+ Enable zlib support for lighttpd mod_compress.
+
+config BR2_PACKAGE_LIGHTTPD_BZIP2
+ bool "lighttpd bzip2 support"
+ default n
+ depends on BR2_PACKAGE_LIGHTTPD
+ select BR2_PACKAGE_BZIP2
+ help
+ Enable bzip2 support for lighttpd mod_compress.
+
config BR2_PACKAGE_LIGHTTPD_PCRE
bool "pcre"
default n
diff --git a/package/lighttpd/lighttpd.mk b/package/lighttpd/lighttpd.mk
index a41d9c98e..131e87e72 100644
--- a/package/lighttpd/lighttpd.mk
+++ b/package/lighttpd/lighttpd.mk
@@ -30,6 +30,20 @@ else
LIGHTTPD_CONF_OPT += --without-openssl
endif
+ifeq ($(strip $(BR2_PACKAGE_LIGHTTPD_ZLIB)),y)
+LIGHTTPD_DEPENDENCIES += zlib
+LIGHTTPD_CONF_OPT += --with-zlib
+else
+LIGHTTPD_CONF_OPT += --without-zlib
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_LIGHTTPD_BZIP2)),y)
+LIGHTTPD_DEPENDENCIES += bzip2
+LIGHTTPD_CONF_OPT += --with-bzip2
+else
+LIGHTTPD_CONF_OPT += --without-bzip2
+endif
+
ifeq ($(strip $(BR2_PACKAGE_LIGHTTPD_PCRE)),y)
LIGHTTPD_CONF_ENV += PCRE_LIB="-lpcre"
LIGHTTPD_DEPENDENCIES += pcre