summaryrefslogtreecommitdiff
path: root/package/lzo/lzo.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-12 21:03:28 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-08-24 09:30:40 +0200
commit7fe50869fb98d045cca7a21ebb695f17aa2afd1a (patch)
tree1cd87d7afe7de390a6535ab8121b14cd3425e251 /package/lzo/lzo.mk
parent0ec4298153bd93f8d7efbd1890896fbac5046a7b (diff)
lzo: fix host-lzo build failure when config cache is filled
When the configuration cache has been filled with a value for ac_cv_host, host-lzo fails to detect the target system name. This is due to misbehaving code in the ./configure script. Therefore, we need to autoreconf the package, which in turn requires : * a little fix to the configure.ac file * a little fix to src/Makefile.am * an extraction of important parts of aclocal.m4 into acinclude.m4 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/lzo/lzo.mk')
-rw-r--r--package/lzo/lzo.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/lzo/lzo.mk b/package/lzo/lzo.mk
index ed300562e..bfa66792d 100644
--- a/package/lzo/lzo.mk
+++ b/package/lzo/lzo.mk
@@ -7,6 +7,12 @@ LZO_VERSION:=2.03
LZO_SOURCE:=lzo-$(LZO_VERSION).tar.gz
LZO_SITE:=http://www.oberhumer.com/opensource/lzo/download
LZO_AUTORECONF = NO
+
+# lzo's configure was generated by an old autoconf, and the
+# AC_CANONICAL_TARGET check fails in host-lzo when the cache has been
+# filled with ac_cv_build and ac_cv_host.
+HOST_LZO_AUTORECONF = YES
+
LZO_INSTALL_STAGING = YES
LZO_INSTALL_TARGET = YES
LZO_INSTALL_STAGING_OPT = CC="$(TARGET_CC)" DESTDIR=$(STAGING_DIR) install