summaryrefslogtreecommitdiff
path: root/package/microperl
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-08-04 15:48:40 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2009-08-04 15:48:40 +0200
commit6cd57ce392233177261d218a8697c92bd0f9a764 (patch)
tree0addab0e6e9a79441cb4746b4000f38d4061c117 /package/microperl
parent5b72dda69f72e1953dfc7987dd1b418e1afe79a4 (diff)
microperl: fix build
Fix the little build systems hacks that no longer applied to the version of Perl being used. With these fixes in place, microperl builds and runs properly simple Perl commands on the target. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/microperl')
-rw-r--r--package/microperl/microperl.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/microperl/microperl.mk b/package/microperl/microperl.mk
index 5a41f384d..f2a958b7a 100644
--- a/package/microperl/microperl.mk
+++ b/package/microperl/microperl.mk
@@ -33,8 +33,8 @@ $(MICROPERL_DIR)/.host_configured: $(MICROPERL_DIR)/.source
$(MICROPERL_DIR)/.host_configured_and_fixed: $(MICROPERL_DIR)/.host_configured
- $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/makefile
- $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/x2p/makefile
+ $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/Makefile
+ $(SED) 's/^.*<command-line>.*//g' $(MICROPERL_DIR)/x2p/Makefile
touch $@
$(MICROPERL_DIR)/.host_make: $(MICROPERL_DIR)/.host_configured_and_fixed
@@ -42,7 +42,6 @@ $(MICROPERL_DIR)/.host_make: $(MICROPERL_DIR)/.host_configured_and_fixed
touch $@
$(MICROPERL_DIR)/.host_make_fixed: $(MICROPERL_DIR)/.host_make
- $(SED) 's#^.*<asm/page.h>.*##g' $(MICROPERL_DIR)/ext/IPC/SysV/SysV.c
$(MAKE) -C $(MICROPERL_DIR) test || echo "An error is expected on make test"
touch $@