summaryrefslogtreecommitdiff
path: root/package/mtd/mtd.mk
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
committerEric Andersen <andersen@codepoet.org>2005-02-10 03:06:39 +0000
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/mtd/mtd.mk
parent040f60b3ea53947675333e60e14838ddd9944abd (diff)
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/mtd/mtd.mk')
-rw-r--r--package/mtd/mtd.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/mtd/mtd.mk b/package/mtd/mtd.mk
index ea1cf31f1..f0a230240 100644
--- a/package/mtd/mtd.mk
+++ b/package/mtd/mtd.mk
@@ -96,3 +96,11 @@ mtd-dirclean:
rm -rf $(MTD_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_MTD)),y)
+TARGETS+=mtd
+endif