summaryrefslogtreecommitdiff
path: root/package/mtd
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
commit9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6 (patch)
tree3f0ef80e7c44f59eae59c0fdfb9b56882d454112 /package/mtd
parent9fba54740004859fd7e0936cda64d01c2b48633b (diff)
Remove usage of TARGET_LDFLAGS all together. Both TARGET_CFLAGS and TARGET_LDFLAGS are passed with the compilers and linker respectively so that we can pass CFLAGS and LDFLAGS on a per-package basis which was not possible previously and a number of packages failed to build. TARGET_CFLAGS usage in package makefiles will be removed next.
Diffstat (limited to 'package/mtd')
-rw-r--r--package/mtd/mtd.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/mtd/mtd.mk b/package/mtd/mtd.mk
index d57922d64..0d7572afd 100644
--- a/package/mtd/mtd.mk
+++ b/package/mtd/mtd.mk
@@ -115,7 +115,7 @@ MTD_TARGETS_$(BR2_PACKAGE_MTD_DOC_LOADBIOS) += doc_loadbios
MTD_BUILD_TARGETS := $(addprefix $(MTD_DIR)/util/, $(MTD_TARGETS_y))
$(MTD_BUILD_TARGETS): $(MTD_DIR)/.unpacked
- $(MAKE) CC=$(TARGET_CC) CFLAGS="-I$(MTD_DIR)/include -I$(LINUX_HEADERS_DIR)/include $(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)" LINUXDIR=$(LINUX_DIR) -C $(MTD_DIR)/util
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) CFLAGS="-I$(MTD_DIR)/include -I$(LINUX_HEADERS_DIR)/include" LINUXDIR=$(LINUX_DIR) -C $(MTD_DIR)/util
MTD_TARGETS := $(addprefix $(TARGET_DIR)/usr/sbin/, $(MTD_TARGETS_y))