summaryrefslogtreecommitdiff
path: root/package/multimedia/alsa-lib
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-18 23:26:25 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-18 23:26:25 +0200
commit538773a66f2e71ac29cf799e3249737dd6903c8e (patch)
tree21808b9bc5d25793ff2865d1c44e32d13d7dcef5 /package/multimedia/alsa-lib
parent4a2dabe9d53e6c361ecdeaba0431ef74a9ad297c (diff)
alsa-lib: make sure to only look in STAGING_DIR for Python includes
Even though we pass a -I option to tell alsa-lib to look for Python includes in the STAGING_DIR, alsa-lib build process still looks in /usr/include for some stuff, causing bug #321. This fix is the one suggested by Ulf Samuelsson in bug #321, and allows to make alsa-lib with Python support to build properly on a 64 bits machine with python-dev installed on the host. Without this fix, the build fails with exactly the same problem that Ulf reported. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/multimedia/alsa-lib')
-rw-r--r--package/multimedia/alsa-lib/alsa-lib.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/multimedia/alsa-lib/alsa-lib.mk b/package/multimedia/alsa-lib/alsa-lib.mk
index 1f120c6f7..6e4c5754f 100644
--- a/package/multimedia/alsa-lib/alsa-lib.mk
+++ b/package/multimedia/alsa-lib/alsa-lib.mk
@@ -54,7 +54,9 @@ ALSA_LIB_CFLAGS+=-DAVR32_INLINE_BUG
endif
ifeq ($(BR2_PACKAGE_ALSA_LIB_PYTHON),y)
-ALSA_LIB_CONF_OPT += --with-pythonlibs=-lpython$(PYTHON_VERSION_MAJOR)
+ALSA_LIB_CONF_OPT += \
+ --with-pythonlibs=-lpython$(PYTHON_VERSION_MAJOR) \
+ --with-pythonincludes=$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
ALSA_LIB_CFLAGS+=-I$(STAGING_DIR)/usr/include/python$(PYTHON_VERSION_MAJOR)
ALSA_LIB_DEPENDENCIES = libpython
else