summaryrefslogtreecommitdiff
path: root/package/multimedia
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2009-12-04 00:02:02 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-12-08 21:49:55 +0100
commit989565d30543b2fecd3120a086579209a52704b9 (patch)
tree45202d2710a724b45af0f84af63bc09612ef6237 /package/multimedia
parent1dc19c44570031e28ad40a46f4184c5860371eac (diff)
tremor: add patch to export all symbols
Tremor comes with a Version_script file that limits the list of exported symbols. Without these symbols we can't build the ivorbisdec GStreamer plug-in (and probably other application). This commit adds a patch that removes this limitation and makes all global symbols available. Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia')
-rw-r--r--package/multimedia/tremor/tremor-export-all-symbols.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/package/multimedia/tremor/tremor-export-all-symbols.patch b/package/multimedia/tremor/tremor-export-all-symbols.patch
new file mode 100644
index 000000000..127d16bc5
--- /dev/null
+++ b/package/multimedia/tremor/tremor-export-all-symbols.patch
@@ -0,0 +1,32 @@
+--- tremor-16259-orig/configure.in 2009-12-02 11:45:11.000000000 +0100
++++ tremor-16259/configure.in 2009-12-03 16:50:19.000000000 +0100
+@@ -72,23 +72,6 @@
+ LDFLAGS="$LDFLAGS $ldflags_save"
+
+
+-# Test whenever ld supports -version-script
+-AC_PROG_LD
+-AC_PROG_LD_GNU
+-if test "x$lt_cv_prog_gnu_ld" = "xyes"; then
+- SHLIB_VERSION_ARG="Wl,--version-script=Version_script"
+-
+- dnl Set extra linker options
+- case "$target_os" in
+- linux* | solaris* )
+- SHLIB_VERSION_ARG="-Wl,--version-script=Version_script"
+- ;;
+- *)
+- ;;
+- esac
+- LDFLAGS="$LDFLAGS $SHLIB_VERSION_ARG"
+-fi
+-
+ dnl --------------------------------------------------
+ dnl Options
+ dnl --------------------------------------------------
+@@ -128,4 +111,4 @@
+ AC_SUBST(DEBUG)
+ AC_SUBST(PROFILE)
+
+-AC_OUTPUT(Makefile Version_script)
++AC_OUTPUT(Makefile)