summaryrefslogtreecommitdiff
path: root/package/mysql_client/mysql_client-5.1.53-configure-ps-cache-check.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-22 14:07:08 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-22 21:45:41 +0100
commit24b27158cf103b15b3dd518bbb1b6301a3b0449d (patch)
treed3e5cb4376e26141f2736c7911994096589a20a3 /package/mysql_client/mysql_client-5.1.53-configure-ps-cache-check.patch
parent6ddf4702647e46a09c15bedbe99017eaa10573e3 (diff)
mysql_client: bump to 5.1.53 to fix abi check problem
MySQL 5.1.47 is affected by a bug in one test called the "ABI check", which does not work with recent gcc versions. This bug is referenced as http://bugs.mysql.com/bug.php?id=52514 in MySQL bug tracker. Since it has been fixed in newer versions of MySQL, we simply bump the version to the latest available in the 5.1.x series. The patches have not changed, they have only been refreshed. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/mysql_client/mysql_client-5.1.53-configure-ps-cache-check.patch')
-rw-r--r--package/mysql_client/mysql_client-5.1.53-configure-ps-cache-check.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/package/mysql_client/mysql_client-5.1.53-configure-ps-cache-check.patch b/package/mysql_client/mysql_client-5.1.53-configure-ps-cache-check.patch
new file mode 100644
index 000000000..336e80e0b
--- /dev/null
+++ b/package/mysql_client/mysql_client-5.1.53-configure-ps-cache-check.patch
@@ -0,0 +1,39 @@
+Patch borrowed from
+http://cgit.openembedded.org/cgit.cgi/openembedded/tree/recipes/mysql/files/configure-ps-cache-check.patch
+
+It allows to specify through ac_cv_FIND_PROC how ps should be used on
+the target to find the PID of a program.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+---
+ configure.in | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+Index: mysql-5.1.53/configure.in
+===================================================================
+--- mysql-5.1.53.orig/configure.in
++++ mysql-5.1.53/configure.in
+@@ -462,8 +462,8 @@
+ # then Make, then shell. The autoconf substitution uses single quotes, so
+ # no unprotected single quotes should appear in the expression.
+ AC_PATH_PROG(PS, ps, ps)
+-AC_MSG_CHECKING("how to check if pid exists")
+-PS=$ac_cv_path_PS
++AC_CACHE_CHECK([how to check if pid exists], [ac_cv_FIND_PROC],
++[
+ # Linux style
+ if $PS wwwp $$ 2> /dev/null | grep -- "$0" > /dev/null
+ then
+@@ -502,8 +502,9 @@
+ AC_MSG_ERROR([Could not find the right ps and/or grep switches. Which OS is this? See the Installation chapter in the Reference Manual.])
+ esac
+ fi
+-AC_SUBST(FIND_PROC)
+-AC_MSG_RESULT("$FIND_PROC")
++ac_cv_FIND_PROC="$FIND_PROC"
++])
++AC_SUBST([FIND_PROC], [$ac_cv_FIND_PROC])
+
+ # Check if a pid is valid
+ AC_PATH_PROG(KILL, kill, kill)