summaryrefslogtreecommitdiff
path: root/package/ncurses
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-30 17:47:03 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-01-30 17:47:03 +0000
commit2c272874b82d0a0e4b1412303fcedff638ec9283 (patch)
tree0d56b6adc253be6300cd1fa8fce3ae4a659b4814 /package/ncurses
parent8dc42b0a2e0923adfeedfdf24b050000b045910a (diff)
- explicitely pass the configured $(DISABLE_LFS) in. Also set --disable-big-core
Diffstat (limited to 'package/ncurses')
-rw-r--r--package/ncurses/ncurses.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/ncurses/ncurses.mk b/package/ncurses/ncurses.mk
index f9650213e..a004b7762 100644
--- a/package/ncurses/ncurses.mk
+++ b/package/ncurses/ncurses.mk
@@ -65,7 +65,8 @@ $(NCURSES_DIR)/.configured: $(NCURSES_DIR)/.dist
--with-terminfo-dirs=/usr/share/terminfo \
--with-default-terminfo-dir=/usr/share/terminfo \
--with-shared --without-cxx --without-cxx-binding \
- --without-ada --without-progs $(DISABLE_NLS) \
+ --without-ada --without-progs --disable-big-core \
+ $(DISABLE_NLS) $(DISABLE_LARGEFILE) \
--without-profile --without-debug --disable-rpath \
--enable-echo --enable-const --enable-overwrite \
--enable-broken_linker \
@@ -114,7 +115,7 @@ $(TARGET_DIR)/lib/libncurses.so.$(NCURSES_VER): $(STAGING_DIR)/lib/libncurses.a
touch -c $(TARGET_DIR)/lib/libncurses.so.$(NCURSES_VER)
$(TARGET_DIR)/usr/lib/libncurses.a: $(STAGING_DIR)/lib/libncurses.a
- mkdir -p $(TARGET_DIR)/usr/include
+ -mkdir -p $(TARGET_DIR)/usr/include
cp -dpf $(NCURSES_DIR)/include/curses.h $(TARGET_DIR)/usr/include/ncurses.h
cp -dpf $(NCURSES_DIR)/include/term.h $(TARGET_DIR)/usr/include/
cp -dpf $(NCURSES_DIR)/include/unctrl.h $(TARGET_DIR)/usr/include/