summaryrefslogtreecommitdiff
path: root/package/openssl
diff options
context:
space:
mode:
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-10-13 08:10:35 +0000
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>2008-10-13 08:10:35 +0000
commitbd3dd7b6b9b82660877b9ce4cc45c72b941f4dac (patch)
tree92b44483c85ec3038e0f0625d3d1b27d73824e2c /package/openssl
parentad0984bfa8e56152dcf9d0573bd8b3384093f6b9 (diff)
openssl: fix architecture specified when configuring openssl
This patch will default to linux-generic32, unless a known optimized architecture is selected. As of today it will select optimized config for; avr32, ia64, powerpc and x86_64. This fixes bug #5344. Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/openssl.mk18
1 files changed, 13 insertions, 5 deletions
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index b8c488f5f..5e607fc90 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -6,12 +6,20 @@
OPENSSL_VERSION:=0.9.8g
OPENSSL_SITE:=http://www.openssl.org/source
-OPENSSL_TARGET_ARCH:=
-ifeq ($(BR2_i386),y)
-OPENSSL_TARGET_ARCH:=generic32
+OPENSSL_TARGET_ARCH=generic32
+
+# Some architectures are optimized in OpenSSL
+ifeq ($(BR2_ARCH),avr32)
+OPENSSL_TARGET_ARCH=avr32
+endif
+ifeq ($(BR2_ARCH),ia64)
+OPENSSL_TARGET_ARCH=ia64
+endif
+ifeq ($(BR2_ARCH),powerpc)
+OPENSSL_TARGET_ARCH=ppc
endif
-ifeq ($(OPENSSL_TARGET_ARCH),)
-OPENSSL_TARGET_ARCH:=$(ARCH)
+ifeq ($(BR2_ARCH),x86_64)
+OPENSSL_TARGET_ARCH=x86_64
endif
OPENSSL_INSTALL_STAGING = YES