summaryrefslogtreecommitdiff
path: root/package/openvpn/openvpn.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:25:32 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:36:00 +0200
commit1860bdae8cdf4f9eb7097fd7e5ed7e9c0c5b6a75 (patch)
treeb3b4fb6139799602676e100126c19055b18ac7f0 /package/openvpn/openvpn.mk
parentc106fdbd100f36fe3329360af8f656566937f00a (diff)
parentae2be8dbc36293d8243baf2b13ad17a47738d6d3 (diff)
Merge branch 'for-2010.11/remove-oldstyle-hooks' of git://git.busybox.net/~tpetazzoni/git/buildroot
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/openvpn/openvpn.mk')
-rw-r--r--package/openvpn/openvpn.mk16
1 files changed, 7 insertions, 9 deletions
diff --git a/package/openvpn/openvpn.mk b/package/openvpn/openvpn.mk
index 714938b4b..8d99cab21 100644
--- a/package/openvpn/openvpn.mk
+++ b/package/openvpn/openvpn.mk
@@ -26,20 +26,18 @@ else
OPENVPN_CONF_OPT += --disable-crypto --disable-ssl
endif
-$(eval $(call AUTOTARGETS,package,openvpn))
-
-$(OPENVPN_TARGET_INSTALL_TARGET):
- $(call MESSAGE,"Installing")
- $(INSTALL) -m 755 $(OPENVPN_DIR)/openvpn \
+define OPENVPN_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 755 $(@D)/openvpn \
$(TARGET_DIR)/usr/sbin/openvpn
if [ ! -f $(TARGET_DIR)/etc/init.d/openvpn ]; then \
$(INSTALL) -m 755 -D package/openvpn/openvpn.init \
$(TARGET_DIR)/etc/init.d/openvpn; \
fi
- touch $@
+endef
-$(OPENVPN_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
+define OPENVPN_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/sbin/openvpn
rm -f $(TARGET_DIR)/etc/init.d/openvpn
- rm -f $(OPENVPN_TARGET_INSTALL_TARGET) $(OPENVPN_HOOK_POST_INSTALL)
+endef
+
+$(eval $(call AUTOTARGETS,package,openvpn))