summaryrefslogtreecommitdiff
path: root/package/pango
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-05-21 20:30:28 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-05-21 20:30:28 +0200
commitc89b725978616a24e066e6b01030bdd3fc0ab5c0 (patch)
treec869c538c6d0b7b7c702ef7c24c4c59a89a973b2 /package/pango
parent319a4751c4a3a0209f628a7470a6d8e400d3479d (diff)
parent52e600ebec9cb571edee8f791da851035ae6b969 (diff)
Merge branch '2010-05-15-fixes' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'package/pango')
-rw-r--r--package/pango/S25pango20
-rw-r--r--package/pango/pango.mk18
2 files changed, 22 insertions, 16 deletions
diff --git a/package/pango/S25pango b/package/pango/S25pango
new file mode 100644
index 000000000..9af9307c4
--- /dev/null
+++ b/package/pango/S25pango
@@ -0,0 +1,20 @@
+#!/bin/sh
+#
+# run pango-querymodules if needed
+
+FILE=/etc/pango/pango.modules
+
+case "$1" in
+ start|"")
+ if [ ! -f $FILE ] ; then
+ mkdir -p /etc/pango
+ /usr/bin/pango-querymodules > "$FILE"
+ fi
+ ;;
+ stop)
+ ;;
+ *)
+ echo "Usage: $0 {start|stop}" >&2
+ exit 1
+ ;;
+esac \ No newline at end of file
diff --git a/package/pango/pango.mk b/package/pango/pango.mk
index 38e163e04..c64004584 100644
--- a/package/pango/pango.mk
+++ b/package/pango/pango.mk
@@ -40,16 +40,7 @@ PANGO_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes glib_cv_stack_grows=no \
PANGO_CONF_OPT = --enable-shared --enable-static \
--enable-explicit-deps=no --disable-debug
-HOST_PANGO_CONF_OPT = \
- --disable-static \
- $(if $(BR2_PACKAGE_XORG7),--with-x,--without-x) \
- --disable-debug \
-
-PANGO_DEPENDENCIES = gettext libintl host-pkg-config host-pango libglib2 cairo
-
-HOST_PANGO_DEPENDENCIES = host-pkg-config host-cairo host-libglib2 host-autoconf host-automake
-
-HOST_PANGO_AUTORECONF = YES
+PANGO_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT),gettext libintl) host-pkg-config libglib2 cairo
ifeq ($(BR2_PACKAGE_XORG7),y)
PANGO_CONF_OPT += --with-x \
@@ -61,12 +52,7 @@ else
endif
$(eval $(call AUTOTARGETS,package,pango))
-$(eval $(call AUTOTARGETS,package,pango,host))
$(PANGO_HOOK_POST_INSTALL):
- mkdir -p $(TARGET_DIR)/etc/pango
- $(PANGO_HOST_BINARY) > $(TARGET_DIR)/etc/pango/pango.modules
- $(SED) 's~$(HOST_DIR)~~g' $(TARGET_DIR)/etc/pango/pango.modules
+ $(INSTALL) -m 755 package/pango/S25pango $(TARGET_DIR)/etc/init.d/
touch $@
-
-PANGO_HOST_BINARY:=$(HOST_DIR)/usr/bin/pango-querymodules