summaryrefslogtreecommitdiff
path: root/package/php/php.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:25:32 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-16 13:36:00 +0200
commit1860bdae8cdf4f9eb7097fd7e5ed7e9c0c5b6a75 (patch)
treeb3b4fb6139799602676e100126c19055b18ac7f0 /package/php/php.mk
parentc106fdbd100f36fe3329360af8f656566937f00a (diff)
parentae2be8dbc36293d8243baf2b13ad17a47738d6d3 (diff)
Merge branch 'for-2010.11/remove-oldstyle-hooks' of git://git.busybox.net/~tpetazzoni/git/buildroot
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/php/php.mk')
-rw-r--r--package/php/php.mk17
1 files changed, 10 insertions, 7 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index 9396311ef..68b0b5fc9 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -166,23 +166,26 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_MYSQL),y)
endif
endif
-$(eval $(call AUTOTARGETS,package,php))
-
-$(PHP_HOOK_POST_INSTALL):
+define PHP_INSTALL_FIXUP
rm -rf $(TARGET_DIR)/usr/lib/php
rm -f $(TARGET_DIR)/usr/bin/phpize
rm -f $(TARGET_DIR)/usr/bin/php-config
if [ ! -f $(TARGET_DIR)/etc/php.ini ]; then \
$(INSTALL) -m 0755 $(BR2_PACKAGE_PHP_CONFIG) $(TARGET_DIR)/etc/php.ini; fi
- touch $@
+endef
+
+PHP_POST_INSTALL_TARGET_HOOKS += PHP_INSTALL_FIXUP
-$(PHP_TARGET_UNINSTALL):
- $(call MESSAGE,"Uninstalling")
+define PHP_UNINSTALL_STAGING_CMDS
rm -rf $(STAGING_DIR)/usr/include/php
rm -rf $(STAGING_DIR)/usr/lib/php
rm -f $(STAGING_DIR)/usr/bin/php*
rm -f $(STAGING_DIR)/usr/share/man/man1/php*.1
+endef
+
+define PHP_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/etc/php.ini
rm -f $(TARGET_DIR)/usr/bin/php*
- rm -f $(PHP_TARGET_INSTALL_TARGET) $(PHP_HOOK_POST_INSTALL)
+endef
+$(eval $(call AUTOTARGETS,package,php))