summaryrefslogtreecommitdiff
path: root/package/pkg-gentargets.mk
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-07-03 00:07:08 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-17 20:22:41 +0200
commit46fa5cbfb8f4a94680dc0880db051eb8acee6a17 (patch)
treea3df3b12a820f82953d8ae86397ef4fd939b94c1 /package/pkg-gentargets.mk
parent69e64c42b7f325e6e21d063644eea51204321539 (diff)
Rename XXXTARGETS to xxx-package
With the introduction of a specific macro for host targets, it was decided to also make the names of the macros more intuitive: generic-package, autotools-package and cmake-package. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'package/pkg-gentargets.mk')
-rw-r--r--package/pkg-gentargets.mk14
1 files changed, 6 insertions, 8 deletions
diff --git a/package/pkg-gentargets.mk b/package/pkg-gentargets.mk
index a9cee9099..c01440e64 100644
--- a/package/pkg-gentargets.mk
+++ b/package/pkg-gentargets.mk
@@ -157,7 +157,7 @@ $(BUILD_DIR)/%/.stamp_dircleaned:
rm -Rf $(@D)
################################################################################
-# GENTARGETS_INNER -- generates the make targets needed to build a
+# inner-generic-package -- generates the make targets needed to build a
# generic package
#
# argument 1 is the lowercase package name
@@ -169,7 +169,7 @@ $(BUILD_DIR)/%/.stamp_dircleaned:
# argument 5 is the type (target or host)
################################################################################
-define GENTARGETS_INNER
+define inner-generic-package
# Define default values for various package-related variables, if not
# already defined. For some variables (version, source, site and
@@ -496,17 +496,15 @@ endif # SITE_METHOD
DL_TOOLS_DEPENDENCIES += $(firstword $(INFLATE$(suffix $($(2)_SOURCE))))
endif # $(2)_KCONFIG_VAR
-endef # GENTARGETS_INNER
+endef # inner-generic-package
################################################################################
-# GENTARGETS -- the target generator macro for generic packages
-#
-# Argument 1 is "target" or "host" [optional, default: "target"]
+# generic-package -- the target generator macro for generic packages
################################################################################
# In the case of target packages, keep the package name "pkg"
-GENTARGETS = $(call GENTARGETS_INNER,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
+generic-package = $(call inner-generic-package,$(call pkgname),$(call UPPERCASE,$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),target)
# In the case of host packages, turn the package name "pkg" into "host-pkg"
-host-generic-package = $(call GENTARGETS_INNER,host-$(call pkgname),$(call UPPERCASE,host-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
+host-generic-package = $(call inner-generic-package,host-$(call pkgname),$(call UPPERCASE,host-$(call pkgname)),$(call UPPERCASE,$(call pkgname)),$(call pkgparentdir),host)
# :mode=makefile: