summaryrefslogtreecommitdiff
path: root/package/pkgconfig/pkgconfig.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2008-06-14 21:00:59 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2008-06-14 21:00:59 +0000
commit6eb60364c44be5113ff39abb1e0cacece9595d81 (patch)
treede7d6d6f0185eecd5dc1102ee6ad9e1424e4caea /package/pkgconfig/pkgconfig.mk
parente147608e7d951ee0873d0bf855e98dcbd0230830 (diff)
pkgconfig: bump version and cleanup
Upgrade to pkgconfig 0.23 which has native sysroot support (buggy, but easily fixable), which allows us to get rid of pkgconfig-filter.sh. At the same time cleanup the makefile.
Diffstat (limited to 'package/pkgconfig/pkgconfig.mk')
-rw-r--r--package/pkgconfig/pkgconfig.mk19
1 files changed, 3 insertions, 16 deletions
diff --git a/package/pkgconfig/pkgconfig.mk b/package/pkgconfig/pkgconfig.mk
index 456ad2406..0d41dae0d 100644
--- a/package/pkgconfig/pkgconfig.mk
+++ b/package/pkgconfig/pkgconfig.mk
@@ -3,7 +3,7 @@
# pkgconfig
#
#############################################################
-PKGCONFIG_VERSION:=0.21
+PKGCONFIG_VERSION:=0.23
PKGCONFIG_SOURCE:=pkg-config-$(PKGCONFIG_VERSION).tar.gz
PKGCONFIG_SITE:=http://pkgconfig.freedesktop.org/releases/
PKGCONFIG_DIR:=$(BUILD_DIR)/pkg-config-$(PKGCONFIG_VERSION)
@@ -25,17 +25,8 @@ $(PKGCONFIG_DIR)/.configured: $(PKGCONFIG_DIR)/.unpacked
(cd $(PKGCONFIG_DIR); rm -rf config.cache; \
./configure \
--prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libdir=/lib \
- --libexecdir=/usr/lib \
--sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- --with-pc-path="$(STAGING_DIR)/lib/pkgconfig:$(STAGING_DIR)/usr/lib/pkgconfig" \
+ --with-pc-path="$(STAGING_DIR)/usr/lib/pkgconfig" \
$(DISABLE_NLS) \
$(DISABLE_LARGEFILE) \
)
@@ -46,11 +37,7 @@ $(PKGCONFIG_DIR)/$(PKGCONFIG_BINARY): $(PKGCONFIG_DIR)/.configured
$(STAGING_DIR)/$(PKGCONFIG_TARGET_BINARY): $(PKGCONFIG_DIR)/$(PKGCONFIG_BINARY)
$(MAKE) DESTDIR=$(STAGING_DIR) -C $(PKGCONFIG_DIR) install
- mv $(STAGING_DIR)/usr/bin/pkg-config $(STAGING_DIR)/usr/bin/pkg-config.real
- cp package/pkgconfig/pkgconfig-filter.sh $(STAGING_DIR)/usr/bin/pkg-config
- mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
- rm -rf $(STAGING_DIR)/share/locale $(STAGING_DIR)/usr/info \
- $(STAGING_DIR)/usr/man $(STAGING_DIR)/usr/share/doc
+ rm -rf $(STAGING_DIR)/usr/share/man
pkgconfig: uclibc $(STAGING_DIR)/$(PKGCONFIG_TARGET_BINARY)