summaryrefslogtreecommitdiff
path: root/package/pkgconfig
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-19 11:06:47 +0000
commite7b38c71ce55720f7709f0049f5bfc71ca0615ec (patch)
tree2ce70187ad1380f02c1777e7da3a48fb16d9f26a /package/pkgconfig
parentf58ff9a25f24576e032c65d762e5b8fdd2cf5c1c (diff)
package: add STAMP_DIR and use for host builds
Move stamp (dependency) files outside the (version specific) source directories, so other packages can hardcode dependencies on them instead of having to use <PACKAGE>_VERSION variables. This is important as the variables in the make rules are evaluated when the rules is seen, which might be before the dependent makefile is parsed (and hence <PACKAGE>_VERSION variable is known, screwing up stuff. The downside of this is that the package isn't automatically rebuilt when the version changes (E.G. by a svn update) and you now also have to remove the stamp files next to $(BUILD_DIR)/<PACKAGE>-* to force a rebuild.
Diffstat (limited to 'package/pkgconfig')
-rw-r--r--package/pkgconfig/pkgconfig.mk32
1 files changed, 18 insertions, 14 deletions
diff --git a/package/pkgconfig/pkgconfig.mk b/package/pkgconfig/pkgconfig.mk
index 6c89952c5..206de65c1 100644
--- a/package/pkgconfig/pkgconfig.mk
+++ b/package/pkgconfig/pkgconfig.mk
@@ -21,34 +21,38 @@ $(eval $(call AUTOTARGETS,package,pkgconfig))
PKG_CONFIG_HOST_DIR:=$(BUILD_DIR)/pkg-config-$(PKG_CONFIG_VERSION)-host
PKG_CONFIG_HOST_BINARY:=$(HOST_DIR)/usr/bin/pkg-config
-$(PKG_CONFIG_HOST_DIR)/.unpacked: $(DL_DIR)/$(PKG_CONFIG_SOURCE)
- mkdir -p $(@D)
+$(STAMP_DIR)/host_pkgconfig_unpacked: $(DL_DIR)/$(PKG_CONFIG_SOURCE)
+ mkdir -p $(PKG_CONFIG_HOST_DIR)
$(INFLATE$(suffix $(PKG_CONFIG_SOURCE))) $< | \
- $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
- toolchain/patch-kernel.sh $(@D) package/pkgconfig/ \*.patch
+ $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(PKG_CONFIG_HOST_DIR) $(TAR_OPTIONS) -
+ toolchain/patch-kernel.sh $(PKG_CONFIG_HOST_DIR) package/pkgconfig/ \*.patch
touch $@
-$(PKG_CONFIG_HOST_DIR)/.configured: $(PKG_CONFIG_HOST_DIR)/.unpacked
- (cd $(@D); rm -rf config.cache; \
+$(STAMP_DIR)/host_pkgconfig_configured: $(STAMP_DIR)/host_pkgconfig_unpacked
+ (cd $(PKG_CONFIG_HOST_DIR); rm -rf config.cache; \
+ $(HOST_CONFIGURE_OPTS) \
+ CFLAGS="$(HOST_CFLAGS)" \
+ LDFLAGS="$(HOST_LDFLAGS)" \
./configure \
- --prefix=$(HOST_DIR)/usr \
- --sysconfdir=$(HOST_DIR)/etc \
+ --prefix="$(HOST_DIR)/usr" \
+ --sysconfdir="$(HOST_DIR)/etc" \
--with-pc-path="$(STAGING_DIR)/usr/lib/pkgconfig" \
--disable-static \
)
touch $@
-$(PKG_CONFIG_HOST_DIR)/.compiled: $(PKG_CONFIG_HOST_DIR)/.configured
- $(MAKE) -C $(@D)
+$(STAMP_DIR)/host_pkgconfig_compiled: $(STAMP_DIR)/host_pkgconfig_configured
+ $(MAKE) -C $(PKG_CONFIG_HOST_DIR)
touch $@
-$(PKG_CONFIG_HOST_BINARY): $(PKG_CONFIG_HOST_DIR)/.compiled
- $(MAKE) -C $(<D) install
+$(STAMP_DIR)/host_pkgconfig_installed: $(STAMP_DIR)/host_pkgconfig_compiled
+ $(MAKE) -C $(PKG_CONFIG_HOST_DIR) install
+ touch $@
-host-pkgconfig: $(PKG_CONFIG_HOST_BINARY)
+host-pkgconfig: $(STAMP_DIR)/host_pkgconfig_installed
host-pkgconfig-clean:
- rm -f $(addprefix $(PKG_CONFIG_HOST_DIR)/,.unpacked .configured .compiled)
+ rm -f $(addprefix $(STAMP_DIR)/host_pkgconfig_,unpacked configured compiled installed)
-$(MAKE) -C $(PKG_CONFIG_HOST_DIR) uninstall
-$(MAKE) -C $(PKG_CONFIG_HOST_DIR) clean