summaryrefslogtreecommitdiff
path: root/package/pkgconfig
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-18 19:19:10 +0000
commit77754571b2f327636ce0072cfabc9ce0c9a6ad86 (patch)
tree56fc2d3552653caaa20ee7577b1a04375f80bf28 /package/pkgconfig
parent344d59d788d697f4f6704dd920cad615318e47be (diff)
pkgconfig: add pkgconfig package for target
The host versions shouldn't be visible in Kconfig, so remove the reference to BR2_PACKAGE_PKGCONFIG everywhere and prefix the host targets with host-. At the same time add pkgconfig for the target (E.G. for development) and let BR2_PACKAGE_PKGCONFIG control that package. Notice: all defconfigs in the tree have been updated, but make sure to disable the pkgconfig package (unless you want it) if you use an external config, otherwise you'll end up with pkgconfig and glib2 in the target.
Diffstat (limited to 'package/pkgconfig')
-rw-r--r--package/pkgconfig/Config.in1
-rw-r--r--package/pkgconfig/pkgconfig.mk38
2 files changed, 18 insertions, 21 deletions
diff --git a/package/pkgconfig/Config.in b/package/pkgconfig/Config.in
index 2e6ac7db1..cd2852df6 100644
--- a/package/pkgconfig/Config.in
+++ b/package/pkgconfig/Config.in
@@ -1,5 +1,6 @@
config BR2_PACKAGE_PKGCONFIG
bool "pkg-config"
+ select BR2_PACKAGE_LIBGLIB2
help
pkg-config is a system for managing library compile/link
flags that works with automake and autoconf. It replaces
diff --git a/package/pkgconfig/pkgconfig.mk b/package/pkgconfig/pkgconfig.mk
index 22ce1c799..00fd9582c 100644
--- a/package/pkgconfig/pkgconfig.mk
+++ b/package/pkgconfig/pkgconfig.mk
@@ -3,18 +3,23 @@
# pkgconfig
#
#############################################################
-PKGCONFIG_VERSION:=0.23
-PKGCONFIG_SOURCE:=pkg-config-$(PKGCONFIG_VERSION).tar.gz
-PKGCONFIG_SITE:=http://pkgconfig.freedesktop.org/releases/
+PKGCONFIG_VERSION = 0.23
+PKGCONFIG_SOURCE = pkg-config-$(PKGCONFIG_VERSION).tar.gz
+PKGCONFIG_SITE = http://pkgconfig.freedesktop.org/releases/
-# pkgconfig for the host
-PKGCONFIG_HOST_DIR:=$(BUILD_DIR)/pkg-config-$(PKGCONFIG_VERSION)-host
-PKGCONFIG_HOST_BINARY:=$(HOST_DIR)/usr/bin/pkg-config
+ifeq ($(BR2_ENABLE_DEBUG),y) # install-exec doesn't install aclocal stuff
+PKGCONFIG_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) install-exec
+endif
+
+PKGCONFIG_DEPENDENCIES = uclibc libglib2
-$(DL_DIR)/$(PKGCONFIG_SOURCE):
- $(call DOWNLOAD,$(PKGCONFIG_SITE),$(PKGCONFIG_SOURCE))
+PKGCONFIG_CONF_OPT = --with-installed-glib
-pkgconfig-source: $(DL_DIR)/$(PKGCONFIG_SOURCE)
+$(eval $(call AUTOTARGETS,package,pkgconfig))
+
+# pkgconfig for the host
+PKGCONFIG_HOST_DIR:=$(BUILD_DIR)/pkgconfig-$(PKGCONFIG_VERSION)-host
+PKGCONFIG_HOST_BINARY:=$(HOST_DIR)/usr/bin/pkg-config
$(PKGCONFIG_HOST_DIR)/.unpacked: $(DL_DIR)/$(PKGCONFIG_SOURCE)
mkdir -p $(@D)
@@ -39,21 +44,12 @@ $(PKGCONFIG_HOST_DIR)/.compiled: $(PKGCONFIG_HOST_DIR)/.configured
$(PKGCONFIG_HOST_BINARY): $(PKGCONFIG_HOST_DIR)/.compiled
$(MAKE) -C $(<D) install
-host-pkgconfig pkgconfig: $(PKGCONFIG_HOST_BINARY)
+host-pkgconfig: $(PKGCONFIG_HOST_BINARY)
-host-pkgconfig-clean pkgconfig-clean:
+host-pkgconfig-clean:
rm -f $(addprefix $(PKGCONFIG_HOST_DIR)/,.unpacked .configured .compiled)
-$(MAKE) -C $(PKGCONFIG_HOST_DIR) uninstall
-$(MAKE) -C $(PKGCONFIG_HOST_DIR) clean
-host-pkgconfig-dirclean pkgconfig-dirclean:
+host-pkgconfig-dirclean:
rm -rf $(PKGCONFIG_HOST_DIR)
-
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_PKGCONFIG),y)
-TARGETS+=pkgconfig
-endif